Eqview seems to load stationview and miss recent data

Would it be possible to change the filter in Eqview to exclude all Stationview information? I find the stations marked on the map obscure the earthquakes.
Also would it be possible to include the recent earthquake information in Eqview Magnitude dropdown, it always seems to be a few days out of date.
Hugh Morel

Hello Hugh,

It is possible to hide all the stations by clicking on the Settings button (low left) and toggling the “Show Stations” switch off.

I have already alerted our team to check regarding the missing more recent quakes, and I’m sure they will be able to solve the issue in the coming days.

Thank you for your notification!