Download RS Waveforms Offline

Hey all,

So I am a graduate student interested in eventually using a number of Raspberry Shakes to set up a small network to do some research for my project. I have procured one RS and am just trying to figure out how I would like to set it up so I could check and retrieve data from a RS buried in a seismic vault via the Ethernet cable. I’m a lifelong Windows user and all of my education is in geology, so a lot of the stuff in the guides (which I’ve perused extensively) and other posts still goes over my head.

My question is this: What would be the easiest way for me to download and view the waveforms from the RS to a laptop in the field via the Ethernet port without access to any sort of Internet connection? (The RS will have a GPS on it to keep the time, but nothing else). Apologies if this seems a basic question or is well covered in the guide and I just don’t have the technical know-how to realize it. I’ve managed to ssh into the RS using PuTTY and the Discovery IP successfully but I kind of don’t know where to go from there.

Any and all help would be very much appreciated, whether it’s specific instructions or just directions toward tutorials or other online resources to help me get my feet under me. I’ve already learned a lot about seismic vault construction from this community, so thank you in advance for any help you can provide!

Hi @dbehrens17, welcome to the community! We’re excited that you are using Shakes for your research! I give a detailed response below but there’s also some good information that relates to your questions at How to visualize the waveforms — Instructions on Setting Up Your Raspberry Shake.

Viewing waveforms

The best way to view the Shake’s waveforms quickly is to use SWARM, an open-source project developed originally by the Alaska Volcano Observatory at the USGS. The Shake has a pre-configured SWARM download button right on its web interface (see below), so once you’ve clicked that, follow our setup instructions for SWARM and you should be able to connect to the Shake with minimal configuration on your part (i.e. the server settings will all be set for you by the Shake itself so that you can connect directly to it and view waveforms).


SWARM also has decent documentation here: USGS: Volcano Hazards Program
and our manual has a bunch of good SWARM information here: How to visualize the waveforms — Instructions on Setting Up Your Raspberry Shake

Downloading waveforms

The easiest way to download the waveforms from a field station via Windows is probably by using the FileZilla Client to take advantage of the Shake’s SSH/SCP services, which allow you to transfer data directly accross a SSH connection.

You’ll need to input these parameters into the Connect bar of FZ:
Host: rs.local (or the IP you get from Discovery IP)
Username: myshake
Password: [your Shake's password]
Port: 22

Then, you’ll navigate to


and download the daily miniSEED files you want from that directory to your Windows machine (note that the capitalized names will be set according to your Shake’s call letters and sensor setup).

SWARM can also open miniSEED files on disk, so once you’ve downloaded them you can simply go to File > Open File… and point it to the data you want to investigate.

If you have any issues with this, please let us know and we’d be happy to help.

Firstly, thanks so much for the in-depth explanation Ian, this looks exactly like what I need! I appreciate the help. A couple of follow-up questions if you wouldn’t mind. For SWARM, I’ve got it downloaded, and have followed the video tutorial you guys have on it. In the window on the left under “myshake” there is no “Networks” folder or any sign that SWARM is connected to my shake.

Is this because the shake is just plugged directly into the computer via the Ethernet cable and is not plugged directly into a router or Ethernet jack on the wall (my only option on the university network unfortunately)? Not the hugest problem since thanks to you I know I can just open miniSEED files directly on SWARM, but that was a question I had.

Figured out my second question so I removed it, I didn’t realize you could also navigate up the directory, I think this should work! However, I guess I do have a new problem that I have a question on. So looking at the files in said directory, I’ve moved them over to SWARM and have been able to open them no problem. However, these files were last modified back in March, so they couldn’t be data that’d I’d been collecting over the last few hours with my shake on, could it? Or am I misunderstanding something here. Is there a reason my shake wouldn’t be saving the data locally? I thought it was automatically done that way for a week, but I could have misunderstood. I’ve attached a screenshot just to show what I’m looking at.

Thank you again for all the help you’ve given me so far, I appreciate you taking the time to explain what must be some pretty simple stuff to most!

1 Like

You’re welcome!

Probably, yes. The most likely solution for this is to go into the adapter settings for your Ethernet connection and set your computer’s IP to a manual address like, Subnet to, and Gateway/Router to This should put you on the same subnet as the Shake, which should allow you to connect, although depending on your version of Windows some of the terms could be slightly different.

That’s probably related to the fact that the Shake has the wrong time set in the OS, because it’s not been able to contact the internet or use a GPS for timing. Can you SSH into the shake and send me the output of the following command:

date +%Y.%j

More on timing here:


Hey Ian,

Okay that Swarm thing makes sense, I was just curious.

The response to that command is “2019.075”. I do have a GPS antenna for it, I just hadn’t tried to set it up with the Shake yet because I thought it might be able to get its time from the computer.

Yep, the clock on your Pi is stuck back in March—running just the date command without the formatting options after will give you the exact date and time that it’s using. This is normal, as the Pi doesn’t have a timing chip like most other devices, so it can’t keep track of time correctly when it’s unplugged, and the clock will drift by seconds per day if it doesn’t have either NTP or GPS date input. Setting up the GPS will correct this, although the data you’ve already collected will remain datestamped as having been recorded on March 13.

Unfortunately, unless you set your computer up to be an NTP server and set the Shake to use that server, it doesn’t work like that. It is possible if you want to go that route, but I’d recommend the GPS, since that’s what you’ll be using in the field.

Okay, that makes sense, I agree it’s not worth setting up the computer to be and NTP server. Okay this should be my last question and then I probably won’t be bugging your for a bit at least hopefully. So I’ve booted up my RS with the GPS Antenna sold by you guys, time is all synced up correctly which is awesome. I was reading this section of the user manual just to get a better understanding of what is going on and I wanted to use the ntpq -p command to double check that it’s getting its timing from the GPS now. This is what I ended up looking at.


From my understanding the row with the * symbol is the one the RS is actually using for timing, which would mean in this case it is not yet actually using the GPS correct and using some other NTP? Shouldn’t it be since it is not connected to the internet? Or am I misunderstanding something and these are both the GPS?

Edit: And one more quick query while I have you. For some reason my desktop is able to access the web front end at rs.local/ when connected to the RS via the Ethernet cable while the laptop I would use in the field to collect data is not able to load the web front end when attached to the Ethernet cable. I know from the manual that you can’t just pull the plug on the RS without damaging the SD card, so I was wondering if there was a way to shut down the RS safely without access to the web front end? Maybe something via PuTTY? I appreciate your willingness to help me as my questions have changed!

That’s correct, the GPS device you bought has what’s called Pulse Per Second timing, or PPS, which is a high-reliability way of keeping time. So in this case, the fact that it’s using PPS is good, but not all GPS devices have this capability. I will let @branden know to update the manual.

A couple things to try:

  1. Going directly to the Shake’s IP address rather than http://rs.local. It’s possible that the laptop doesn’t pick up the hostname correctly.
  2. Another possibility is that it’s looking on the wrong subnet or has the wrong adapter settings, but perhaps not if you’ve already tried my earlier suggestion.
  3. Does your laptop see the internet if you plug into a working network jack? This is a simple one but perhaps the adapter is just turned off in the Windows network settings.

Either way, it’s probably best to figure out that problem rather than simply pulling the plug on the Shake, since it will decrease the life of the SD card.

Thanks Ian!

I tried the earlier suggestion but was unable to get it to work initially. I’ll try a little harder and see what I can figure out on my end. Thanks again for all the help!


This functionality was added in V0.16. See rs.local >> Actions icon >> DOWNLOADS >> DATA


Hello Branden!

I have been trying this functionality on both firefox and chromium with Filezilla but the “DOWNLOADS >> DATA” button is not opening Filezilla. Firefox does nothing and chromium is trying to open xdg-open but my credentials won’t work. Is there any previous step needed to use this shortcut?
I am using Filezilla just fine without the web interface so this is just to ease my mind and curiosity

1 Like

Hello alexander132,

Unfortunately, since the time when this functionality has been implemented, browsers have added more security protocols that in some cases create what you have been experiencing.

In such cases, the fastest solution is to use Filezilla directly, by setting a dedicated profile in this way:


It is very straightforward and it will give you direct access to the contents of the microSD card inside the Shake. You will be able to then download the data by accessing the following folder:


and navigating through the year, network, and shake folders. You could even pre-set the login profile that you have created to the folder you are more interested in, so that you will save time.

I have noted your message, nonetheless, and we will see in which future Shake OS release this feature can be improved.