Dataview question

When I run dataview in Windows 10 and linux mint it will not show live data display or the 24 hour display. I did get to run one time on this computer running windows 10 then it would not work again.
I logged off rebooted came back and have not gotten the 2 views (multi view and 24 Hr display) and to load again
Like I said multiview loads just fine.

What am I doing wrong? When I first starting using dataview i could get all three display options to work, then it quit and will only show the multiview display.

I use firefox and chromium browser. I get the same results when I try microsoft edge browser too.
Any help is appreciated…

This happens on 2 computers. I running windows 10 and linux the other Linux only

I would start by looking at any firewall blocking outgoing connections on non HTTP/HTTPS ports and possibly other protocols.
Especially if Windows firewall is running - try disabling that.

1 Like

Already done that. Also I am not running a vpn either.

Thanks for the reply

1 Like

Hello reelfoot, and welcome to our community.

I’ve tried to replicate this issue on my Win11 and Win11 PCs, but I was unable to, but I remember another user with a similar issue in the past, and here are the steps that were followed to solve it (you may have already done some of them).

  • can you please try to hard refresh the DataView page with Ctrl+F5
  • try to access it in incognito mode to see if the problem disappears
  • update Chrome to its latest version
  • update Javascript to its latest version
  • erase all cookies and site data from all domains
  • check if all the ports listed on our manual (Firewall issues?) are open for your network. In this specific case, port 443 is probably what is causing your problem, thus resulting in you not being able to visualize DataView in full.

If the problem persists, could you please open the Console in Chrome with F12 and post a screenshot of what it says?

Thank you.

I am not using chrome. I use firefox. I tried with chromiun and edge to see if it made a difference and it didn’t.
I works sometimes and sometimes it does not. Makes no sense it will work with multi stream but usually don’t work with 24 hr view and live data display.
I will try what you wrote and see if it helps. This is happening on 2 different computers and with 2 Os systems Windows 10 and Linux Mint (latest edition)

I just discovered this 1 works 1 does not.
My firewall is off on both computers ,cache is clean, java is up to date antivirus turned off.
This is what I discovered.
This link works: Data View: Raspberry Shake Data Visualization Tool

This link only shows multiview: Data View: Raspberry Shake Data Visualization Tool

Click the link in my above post and you will see the 2 addresses. Don’t know why it don’t show up here.

Hello reelfoot,

Yes, the situation is indeed unusual, as the behavior is inconsistent and carries across different OSes as you have noted.

In Firefox, could you please press F12 and then select Console in the window that appears, then posting a screenshot of what the display shows for both links?

In my computer (Win11) the first link that you posted loads the indicated station without issues

while the second shows the base version of DataView, before the user selects any station from the list on the left side popup:

The link will work now.the device was unplugged by my cat of all things and I didn’t notice until after I logged off and tried to check again about 2 hours later.

I can get the console up but I do no know how to take a screenshot of it. I know firefox has screenshot in it. That’s about all I know about it lol never used it before.
Help ?

I only have this problem when I click data view from the shake homepage.

I just bookmarked the link after I opened it. So I just don’t use that link and all is fine with windows 10 and linux. Sorry for the confusion

the 2 links i 1st posted works with dataview in multi data stream,24 hr display and live data display.
Now that they both are online…

Thank you for the additional details reelfoot, we will investigate more about why the link from our homepage seems to cause the issue, while a direct one (as you have bookmarked) works without issues.

No problem ata all. In any case, thank you for your feedback and glad to hear that you are able to access the data from your Shake now!