DataView not working in Chrome

I’m getting the following JavaScript error in Chrome when trying to access the DataView (for any station):
image

I am able to succesfully load the DataView in Microsoft Edge (no errors shown in the console). Chrome was working for me a few hours ago. I tried force-refreshing the page (shift + F5) but that didn’t seem to help.

1 Like

Just had the same thing happen now in Edge. It seems that keeping the DataView open for a few hours causes this issue? When I open a private browsing tab the issue seems to be resolved temporarily, so it’s some sort of caching thing?

What OS? I have mine open 24/7 on MacOS. No problems.

Windows 10. The page is completely white when I get this error, none of the interface loads at all. It’s very strange.

Hello guillochon,

I’ve tried to replicate this issue on my Win11 and Win10 PCs, but I was unfortunately unable to. Can you please try to hard refresh the DataView page with Ctrl+F5 (if you haven’t already), or try to access it in incognito mode, to see if the problem disappears?

This may reveal some clues on what is going on.

Also, when you can, please (again, if you haven’t already) download and install the latest Java package from their website: https://www.java.com/en/download/

OK got it working again for now at least. Here’s some things I tried that didn’t work:

  • Cleared browser cache
  • Updated Chrome to latest version
  • Updated Java to latest version

What ended up working was clearing all cookies on raspberryshake domains. So I guess I ended up with some corrupted cookies? I think it might have something to do with me favoriting stations in the dataview. If it recurs I will reply here.

2 Likes

Thank you for the feedback guillochon.

And yes, please notify us again if something similar happens, thank you!

@Stormchaser I have some more info: the issue recurred again this morning, I cleared specifically the cookie on the dataview.raspberryshake.org domain and it was fixed again. I had selected some sites as favorites in the UI on the DataView page and I suspect that’s the cause. I’m going to let it run again for a few days without selecting any favorites to see if it recurs again.

2 Likes

Thank you for this additional feedback guillochon, and for the time you are taking for these tests!

Has not recurred since. I think the favorites feature is likely the culprit.

1 Like

Thanks again, I will pass this info to our software team, and they will take a deeper look at it.

Hopefully, it will be something easy to solve.