Damaged 1D shake

I have an unusual circumstance here. The unit was placed in an area where it was not sufficiently protected, which resulted in 2 issues. A groundhog dug a tunnel next to it and a significant amount of dirt entered the opening in the case. Spiders also found their way in. see link

I first cleaned it by disassembling and brushing off all debris. I also removed and cleaned the SD card and cycled it in and out of the slot multiple times to try and clean the contacts. Upon reassembly the ethernet and indicator lights appeared normal but I cannot connect to it. I next cleaned it using an electronic cleaning solvent and repeated the connection attempt.

I assume at this point I need a new unit but am looking for advice.

Hello Russell,

That definitely seems a situation where good cleaning was the perfect choice to make. It’s a curious thing with both groundhogs and spiders nonetheless.

Checking connections was also good, especially after cleaning all that dirt and murk from the Shake.

Can you expand on “I cannot connect to it”? Do you mean that you cannot access via the rs.local interface?

From what you said of the lights it seems that power reaches every part of the unit, so, at least, the Shake turns on correctly and possibly loads parts of the software.

Have you tried a direct connection? The how to do it is explained here on our manual: https://manual.raspberryshake.org/ssh.html#direct-connections

Or, when connected to your LAN, can you find it in the list of the devices from your modem/router admin panel? Or, can you find it with an app like Fing (https://www.fing.com/products/fing-app)?

I just tried the terminal connection and it timed out. I had looked for it in FING but did not see it.

Then it’s possible that the Shake OS on the microSD card is not properly working anymore. I advise you to

  1. re-burn the ShakeOS on your current microSD card
  2. or get a new microSD (to erase the chance that this one got ruined) and burn the Shake OS there.

In both cases, these are the instructions to prepare the new OS image:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.