Connection to Server failure - R6CCA

My RS was connecting to the server this morning, but after rebooting (I was turning on the Static IP because I need to move the device to campus this week), it no longer connects to the server. It shows up as connected to the router and on fing as well. But no server connection, and it is not showing up on shakenet either.
I tried to open the portals 55555, 55556, and 123. And I tried to ssh in via putty, but I can’t get my password to go in. I see the green box, type in the default password, and I get denied access.

Hello mosawi94, welcome to our community!

Thank you for the logs from your Shake. It indeed appears that the Shake is unable to find a network, from these lines:

2022 053 19:17:27: Network detection failed, unable to curl or ping common sites
2022 053 19:17:27: No internet connection found

Since you have said that the unit was moved to a campus, it is possible that more permissions are needed from the campus IT administrator (like, for example, adding the unit MAC/IP addresses to their firewall exceptions). It would not be the first time that this has happened with school networks, due to their increased security protocols.

Regarding the inability to access via SSH, do you remember if you have changed the password in the past, or have you left the default one shakeme? Have you tried to SSH without PuTTY, via direct command line? You can try to do it by opening your command promptand entering ssh myshake@shake_ip_address. Does it accept the password, or are you still unable to login?

Thank you so much for your help.
It is still not connecting.
I have worked with my university IT and we have determined its IP address/MAC, and according to the network system, it is connected to the university network.
The device shows as RUNNING and Data Forwarding is ON, other than this, everything else is off. It is showing as not connected to the server, and we cannot determine the reason why. I saw online that it needs access to ports 55555 and 55556, but IT doesn’t seem to know what this is?
I am attempting to download the log files, but it is not working and the shake has shut itself down twice already.

1 Like

Hello mosawi94,

Good news regarding the IP/MAC addresses, these are usually the first steps to allow the Shake to communicate through your school network.

Those two are ports that a user would normally open on their network’s modem/router to allow data packet transmission and reception between the Shake and our servers. Your IT should be able to open then from their main control panel.

Regarding the logs, if you cannot download them from the Shake you can try to connect it directly to the pc and manually retrieve them.

These guides show how to do so: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake and Discovery IP — Instructions on Setting Up Your Raspberry Shake

And this how to retrieve the files: How to download your data — Instructions on Setting Up Your Raspberry Shake

Differently to what is written, you will have to navigate to /opt/log to retrieve all the log files that we need.