Connection Timeout on My Station AM.R83DA

My new station R83DA has been installed for two days. Within around six hours of installation it was connecting to the server and viewable in stationview.

When I switch to MyShake in the ShakeNet app, within a few minutes I get a “Connection Timeout”.

This can be cleared by restarting the app, or by switching to another added station and then switching back.

Any ideas to fix this?

Logs attached.

Possibly related … for me, the list of recent earthquakes in the ShakeNet app is not refreshing. I need to clear the cache in Settings and then refresh to get all the latest earthquakes .

Thanks … Neil

RSH.R83DA.2021-02-11T05_50_21.logs.tar (1.2 MB)

Now my station shows as offline in the ShakeNet app, even though rs.local reports it as being connected to the server. :worried:

Latest log files.RSH.R83DA.2021-02-11T09_28_59.logs.tar (1.2 MB)


a glitch on the server has been rectified, your data should be streaming everywhere okay now.



I can confirm seeing the Shake updating live on StationView here on the ShakeApp and on SWARM.

Thanks @ivor.

1 Like

Thanks @ivor. Yes - the station is online again at StationView.

But unfortunately I am still getting the “Connection Timeout” issue in the ShakeNet (iPhone and iPad app) as per the original post, and still having to clear the cache if I want to refresh to the latest list of earthquakes. Is it just me that doesn’t get the latest list of earthquakes without doing that?

Appreciate your help. :blush:

Cheers …… Neil

1 Like


this was a known issue in past versions, but was effectively addressed a couple of updates ago.

please confirm your installed version:

the latest available release is 1.2.2a. if this is not what is installed on your device, please update, or uninstall and reinstall from scratch to make sure you are up to date.


Thanks @ivor. My version was 1.2.2. I deleted the app, and reinstalled. Still 1.2.2. No “a” after that, if that is important?

(This is on iPad OS 14.4, and the NZ App Store.)

that should be okay, the missing ‘a’ would not explain this problem.

that message, when accurate, indicates communication issues between your device and the server. have you tried looking at other stations? does this always happen? in your screenshot there is data, so i assume the initial load is fine, where the message pops up sometime later? or does the message appear and the data continues to stream?

do you know the details of your LAN’s connection to the internet-at-large? what are your up- and down-load speeds?


Thanks Richard.

I’m on a gigabit fibre connection, so Internet speed should not be a problem. The LAN speed for the Raspberry Shake (connected by Ethernet) should be greater than 500 Mbps up and down. My iPad is on wifi, at around 350 Mbps up and down.

After starting up the ShakeNet app and then switching to MyShake and the live stream of EHZ I get Connection Timeout in a time between about 1 and 5 minutes (from three tries just now, one of which was after clearing the cache). The data stops and does not restart, so far as I know.

FWIW I also installed the ShakeNet app on another iPad, and did not log in, but selected R83DA as a Station to livestream. I had both iPads running and they both timed out at the same time, after a few minutes. Does the same thing happen for you if you try livestreaming my station?

(Please ignore the 24 h plot … embarrassingly a large spike from nudging the station in a new location about 12 h ago overwhelms the auto scaling. :roll_eyes: )

Cheers … Neil

P.S. I tried live streaming a nearby RS4D and it happily kept going for 10 minutes with no connection problem, at which point I gave up. So the issue does, for me at least, seem to be with my station.

I also need to clear the cache to get the latest list of earthquakes

A friend of mine has the same problem as well. Unfortunately clearing the cache also removes your list of added stations.

@ivor is this a server issue? Or will it be addressed with the new app release (this month?).

As a new user these services and the app are very much appreciated, BTW. :slightly_smiling_face:



we will need to look into this further. it is confusing that this behaviour seems to be station specific, on the surface, this does not make sense. where is your friend’s phone located, btw?

as for clearing the cache, this suggestion is intended to be employed only once, not repeatedly.

are you able to execute a traceroute command from the network your phone is located on? if so, please run the following from a LINUX command line, from the Shake Pi, for example, and then send me the output:

> traceroute

and, without knowing your specifics, would it be possible to try the mobile app from a different location, where the LAN you’re connecting to is completely different? obviously, your internet speed is not the issue, but when the problem is maintaining a connection to a server, speed may be an irrelevant metric.

before a fix can be applied, we will need to figure out the source of the problem, which is yet unknown. we will investigate what we can on our side and i will update you with any progress in understanding.


Thanks Richard.

Connection Timeout

Here’s the traceroute from the RS:

myshake@raspberryshake:/opt $ traceroute
traceroute to (, 30 hops max, 60 byte packets
 1  ultrahub.hub (  0.736 ms  0.905 ms  1.124 ms
 2 (  4.375 ms  4.332 ms  4.493 ms
 3 (  4.449 ms  4.569 ms (  5.212 ms
 4 (  178.896 ms  178.854 ms  179.157 ms
 5 (  179.901 ms  180.015 ms  179.814 ms
 6 (  330.545 ms  326.146 ms  326.443 ms
 7 (  333.119 ms  333.077 ms  333.194 ms
 8 (  335.250 ms  335.944 ms  335.903 ms
myshake@raspberryshake:/opt $ 

vf is Vodafone NZ (my ISP). I get a similar one from my iPhone on the network.

I’ve tried switching off wifi so my iPhone is connected to the mobile network, and I still get a Connection timeout - though it can take as long as 8 minutes sometimes.

Is there any useful clue from the Traceroute?

ShakeNet App Event List Not Refreshing

To be honest, that Connection Timeout bothers me less than the issue of the latest quakes not refreshing in the ShakeNet app, which I assume is an issue with the (beta, I know) app itself or its connection to the server. I get the same problem on wifi, on mobile, and also the same experience from two friends (one in Wellington and one in Dunedin) running the app on Android.

I also tried deleting the app, rebooting the phone, then reinstalling the app and running it (all on mobile, not my wifi) and still I cannot get the latest quakes to refresh under “Events”. The list remains what it was when the app started up.

Cheers …… Neil

1 Like

hi neil,

the app was updated yesterday, please verify your version is the latest, 1.3.0, and test again to see if you are seeing the same problems.

for the connection timeout problem, we have increased the timeout to 20 seconds (from 13), as an attempt at a short-term solution (to get it into this release). we will be coming up with a longer-term, more robust, solution that does not rely purely on some number of seconds to handle the case when both the instrument and mobile app device are located far from the data server. (we think your problem is a combination of the distance of both.)

regarding the event list not updating: this is strange. both platform versions, android and iOS, poll the event server for updates. does the recent version continue to display this behaviour? if so, i will think about how this can be further analyzed from afar and revert.

cheers, hope the new version behaves better for you,

Thanks Richard.

To make absolutely sure, I deleted the app and reinstalled, and definitely have 1.3.0.

Unfortunately I am still seeing the same behaviour in terms of a Connection timeout and the event list not refreshing.

Furthermore, whenever I start the app I get this alert message appear (odd, because I am on iOS, not Android).

Tapping ok crashes the app. Tapping outside the alert message makes it go away.

Best wishes and thanks for all you do.

Cheers … Neil

hi neil,

there was an issue with the 1.3.0 release that has been updated with an immediate release of version 1.3.1. please update when this becomes available in the apple play store; this will solve the “… no longer supported …” pop-up and crash problem.

i will assume, however, that 1.3.1 will not change your connection timeout and event list update problems. and, now that we know that changing the timeout value does not ameliorate the situation, i will conclude that the both problems (connection timeout and event list not updating) are somehow related.

can you provide more details on how your phone is connected to the internet? is this via a wireless connection to a local router? can you do me a favor and, assuming you have data-over-voice services, turn off the WiFi connection on your phone and see if the you still see the same behaviour?

thanks in advance,

Thanks Richard.

I have good news in relation to the timeout issue. On my iPhone I deleted and then reinstalled ShakeNet (1.3.1) and ran it while connected to mobile data only. After 25 minutes I still did not have a connection timeout issue. However, doing the same think on my iPad, connected to my home wifi, I did get a timeout issue within a few minutes. So it looks like the connection timeout is somehow related to my wifi network. My problem. :flushed:

However, both on the iPhone (connected to mobile data still) and on the iPad (connected to my home wifi) the events list is still not refreshing when I pull down from the top on it. I get red lines at the top moving from left to right, but no new events appear at the top of the list.

If nobody else is experiencing this issue with the Raspberry Shake (ShakeNet) app, perhaps it is a combination of my ISP (Vodafone NZ, for both the landline fibre connection and the mobile data service) and the remoteness of New Zealand from Panama.

In other words, it’s probably me, not you, so if nobody else is having event refresh problems we may as well close off that issue for now as well.

Though I’m happy to help dig further into it if there is something else I can test or debug or trace from my end. Let me know.

In that regard, I used the app “Net Analyser” on my iPhone to ping and trace route when connected to mobile data, and also my home Wi-Fi. Screen captures below, where it’s 4G for mobile and I’ve circled the wifi symbol when I was connected to Wi-Fi.

Best wishes … Neil