Connection issues station AM.R3A5D.00.EH[Z,N,E]

I started my RS3D a few hours ago and it wasn’t long before my sensor showed up on map but I have not seen the Server Connection connect. While attached picture shows a relatively short uptime, it ran for close to an hour and a half earlier. Internet dropped out so rebooted.

Now it does not show my station at all on map, server connection is still not connecting and for whatever reason it isn’t able to tell which Pi model I have which is a Pi 4 B. I have attached picture and the log file.

I am reasonable familiar with Raspberry Pi computers, having used then for other projects. If you look at earthquake map od South Carolina, USA you should see an earthquake that happened yesterday. My station is very close to that quake

.RSH.R3A5D.2022-03-10T23_42_57.logs.tar (224 KB)

Looks to me as though you may have a router/firewall problem.
The networking is up (obviously – you can connect to it), but it can’t connect to services on the Internet:

Mar 10 22:51:30 raspberryshake systemd[1]: Failed to start Network Time Service.

Same issue connecting to the raspberryshake server:

=== Shake Data Server ===
/usr/local/bin/myShake: line 396: NO: command not found
Port 55555 :
/usr/local/bin/myShake: line 396: NO: command not found
Port 55556 :

Network Info

Stand-Alone Mode : OFF
Ethernet UP : YES
DNS Available : YES
Network Accessible : NO
Nameservers :,,

For sure but generally I get a message of some sort that tells me where to look. Locally it seems to be working but I would like to see live data. When I open the My Shake page the three graphs are empty.

I’m stumped.

Any suggestions are welcome because Router and firewall appear to not be problem at least firewall as I turned off both the routers firewall and my AV firewall and made no difference.


1 Like

The best I can suggest is to ssh into the device, and then run traceroute to see where things hang up.
This is what I get ( is my firewall, is the router):

myshake@raspberryshake:/opt $ traceroute
traceroute to (, 30 hops max, 60 byte packets
 1 (  1.523 ms  2.906 ms  3.144 ms
 2 (  4.889 ms  5.227 ms  5.185 ms
 3 (  14.926 ms  28.141 ms  27.278 ms
 4 (  28.855 ms  28.812 ms  29.116 ms
 5 (  28.103 ms  27.884 ms  27.024 ms
 6 (  28.955 ms  20.684 ms  14.789 ms
 7 (  27.872 ms be-36241- (  27.441 ms be-36221- (  26.637 ms
 8 (  26.596 ms be-2211- (  27.313 ms be-2401- (  23.545 ms
 9 (  29.341 ms (  27.969 (  26.564 ms
10  * * *
11 (  28.808 ms  26.088 ms  27.855 ms
1 Like

Hello yellowfin1,

Thank you for contacting us, the screenshot and the logs. I can see that you have two main issues:

  1. Your Pi model is listed as unknown. From our data the Pi4 board that you are using (d03114) should be correctly classified, and not as an “Unknown Model”. This doesn’t prevent your Shake working, but let’s try to solve the connection issue first.

  2. The server connection is listed as “Not Connected” because, from the logs, the Shake cannot access the internet. These lines show the problem:

2022 069 22:51:34: Network detection failed, unable to curl or ping common sites
2022 069 22:51:34: No internet connection found
2022 069 22:51:35: Network detection failed, unable to curl or ping common sites

What I can recommend is to shut down everything, both Shake and modem/router. Then, turn on the modem/router and check that everything is working fine with your other devices connected to it (i.e., that you can connect and navigate the internet).

Now connect the Shake directly to the modem/router with the provided cable (or, if you have another CAT6 or superior cable, please feel free to try that one too) and check if the Shake gets assigned a proper IP address from the modem/router and is visible on its administrator panel, or an app like Fing (Fing App | Network toolkit and scanner | Fing ), which shows all the IP addresses of any device connected to your local network.

If the IP address is correctly assigned, then please access the modem/router admin panel again and check that all necessary ports are open. A complete list can be found here: Firewall issues? — Instructions on Setting Up Your Raspberry Shake

Once all of this has been done, the Shake should be able to connect, but I’ll wait for your feedback before proceeding forward.

I have this RS3D as one component of bigger project to clean up rats nest of power cords and ethernet cables so will tackle shortly.
On attached screenshot, the way it looks to me is my device is running and recording at local level. Can you confirm that it is recording in 12 hour blocks with most recent block being the data to the right side of picture?Helicorder Q


No problem, I will wait for you to manage the cabling clean-up. I had to do it too some months ago, and it was sorely needed.

Yes, if when clicking on each link in the Helicorder page you get an image full of data, then your Shake is correctly recording movement and storing it locally. It is indeed recording in 12 hours block, with the most recent data being always on the left side, as you can see from the dates (03/11 being a day later than 03/10).

I’ve gotten all my various issues relating to router and home network sorted out. As far as this help question, can you delete station R3A5D from system? For all practical purposes it never collected much data and I subsequently installed the Shake OS on a different Pi and was assigned a new station ID R8EB1.
When I go to the My Shake page both stations are listed and it wants to default to the now non-existant station. I unpinned but according to your status legend at lower left is on-line which is impossible as that Pi is laying on my desk turned off with no microSD card inserted. My only station is R8EB1

Hello yellowfin1,

We will take care of that, thank you for notifying us about the change in ID.

Have you tried, when you are in the “MyShake” page, to click on the “Disassociate this station” button that should pop out with your offline station?