Connection failure

Dear colleagues,

Despite my station showing on ShakeNet and trying every setting adjustment suggested in the forum (e.g. setting static IP for my Raspberry Pi; allowing device-specific firewall by-passing and even stopping router firewall totally…), the server connection fails. Please could you kindly see if there is anything diagnostic at your end? Thanks.RSH.RC580.2022-02-22T08_15_51.logs.tar (1.6 MB)

I took a quick look at your logs.
I will leave a definitive interpretation to @Stormchaser, but what I see is this:

Network Info

  Stand-Alone Mode : OFF
       Ethernet UP : YES
           WiFi UP : YES
     DNS Available : YES
Network Accessible : NO
       Nameservers :,,

=== Shake Data Server ===
/usr/local/bin/myShake: line 396: NO: command not found
 Port 55555 : 
/usr/local/bin/myShake: line 396: NO: command not found
 Port 55556 : 

No network (Internet) connectivity. There are NTP errors too.
Looks like it may be a firewall/router problem to me.

1 Like

Thanks, Philip.
I have tried running the router with firewall off for 24 hours, without success, and I think the NTP connection got sorted eventually by assigning a specific router port to the Shake device. The router is one supplied by my broadband provider and seems to have a reputation of being difficult to manage; it is also suggested that ISP withholds critical info about their service, such that switching to a different make of router is not feasible. I will continue to try different settings for IP, DNS, ports etc.

Hello Willy,

Thank you for the logs that you have provided. As Philip suggested, there are possible firewall modem/router issues that are preventing your Shake from connecting to the internet. These lines show it clearly:

2022 052 15:08:05: Network detection failed, unable to curl or ping common sites
2022 052 15:08:05: No internet connection found
2022 052 15:08:05: Network detection failed, unable to curl or ping common sites

What I can recommend is to shut down everything, both Shake and modem/router. Then, turn on the modem/router and check that everything is working fine with your other devices connected to it (i.e., that you can connect and navigate the internet).

Now connect the Shake directly to the modem/router with the provided cable (or, if you have another CAT6 or superior cable, please feel free to try that one too) and check if the Shake gets assigned a proper IP address from the modem/router and is visible on its administrator panel, or an app like Fing (Fing App | Network toolkit and scanner | Fing ), which shows all the IP addresses of any device connected to your local network.

If the IP address is correctly assigned, then please access the modem/router admin panel again and check that all necessary ports are open. A complete list can be found here: Firewall issues? — Instructions on Setting Up Your Raspberry Shake

Once all of this has been done, the Shake should be able to connect, but I’ll wait for your feedback before proceeding forward.

Hello, I’ve experienced a similar issue during setup today. My station, AM.RA3CF, appears on ShakeNet, however, offline within StationViewer. Within rs.local/ everything appears ‘okay’.

This problem has been on-going since initial setup 1 hour ago, power has been consistently provided. The RS is connected to a home network.

Logs attached: RSH.RA3CF.2022-02-23T22_03_59.logs.tar (108 KB)

Thanks for any feedback!

1 Like

Hello Orewa.Steve,

Thank you for explaining the issue and posting the logs from your Shake. From them, nothing appears out of place, and, in fact, the unit is now visible on StationView transmitting live data here: RS StationView

It may take up to 24h for a new instrument to appear on all of our services. Usually, however, it takes less than that.