Connecting directly to computer via ethernet

#1

Hi,
Is it possible to connect my RS directly to my computer’s ethernet port so that I can use the Shake for demo purposes when an internet connection or router is not available?

Thanks,
Steve

#2

YESSSS!

http://manual.raspberryshake.org/no-network.html

We have a program/ manual page just for that. Let us know how we can improve it.

Branden

#3

Cool - that works, thanks!
My only slight complaint is that the appearance of the squiggles in swarm is a bit too jumpy and packetised. Would be nice to see a smoothly appearing trace, like in stationview.

1 Like
#4

I am trying to connect the shake with direct connection but it is not working with ubuntu 18.04. Can you tell me what changes I need to make?

#5

When I try to call ‘ssh myshake@rs.local’ it gives me following error:

ssh: Could not resolve hostname rs.local: Name or service not known

#6

I resolved the hostname error by using the ip assigned to the shake. I used the following way:

ping rs.local (didn’t work)

so I tried with the ip address

ssh myshake@10.42.0.1

but now when I enter the default password which is ‘shakeme’, it doesn’t work. It gives the following error:

Permission denied, please try again.

However, I am using the shake for first time and I have not connected to the internet because I just need it for standalone operation and secondly I have not changed the password because I’m unable to connect the shake since I bought it.

If anyone has solved this issue, please reply.

#7

Hi Shakeel, it sounds like you might not be connecting to the Shake at all but another machine. Are you sure that’s the IP where the Shake is? Have you checked its IP with the Fing app?

#8

p1

Now I just wanted to start the htttp://rs.local/ but it is not working. So I connected the raspberry shake with the lcd display and got the ip address from there.

After getting the IP address I verified it through the fing app.

Now, when I try to access http://rs.local/ it does not work. When I try to use myshake@ip it asks for password but when I give the default password it says “permission denied”.

Please let me know what is the problem? and if it does not work how I can get the data?

Best Regards
Shakeel

#9

I changed the user name to pi@192.168.100.101 and entered the default password for raspberrypi it worked so it seems my raspberry pi didn’t come with the pre-installed raspberry shake system software. It is just another raspberry pi.

So now can you guide me what should I do to make the system run?

Your help will be really appreciated.

#10

Reflash the microSD card with the proper image: diy.raspberryshake.org

branden

#11

Thanks! Everything worked perfectly now.

2 Likes