Connecting data dongle

Hi, I am trying to run my shake with a data dongle. I have followed advice here

but my shake doesn’t appear to have wlan0 configured at all:
myshake@raspberryshake:/opt $ iwconfig
docker0 no wireless extensions.

eth0 no wireless extensions.

lo no wireless extensions.

vetha1d114c no wireless extensions.

eth1 no wireless extensions.

ztrfygcemb no wireless extensions.

veth3f735f4 no wireless extensions.

vethed01909 no wireless extensions.

I am doing this with the shake connected via ethernet to my router, accessing it via wifi on my macbook. I have also tried to connect directly from a windows laptop to the shake via ethernet cable, but neither rs.local, nor the IP address connects.

log files hereRSH.RF2F9.2020-07-20T09_28_07.logs.tar (2.4 MB)

hi jess,

normally you would set up the wireless connection through the front-end interface. where you have your shake connected via ethernet to your router and, using FING or some such other app, specify the IP address of your unit in a browser tab connected to the same subnet.

in absence of the front-end, or if you’d rather do this from the command line, please see the command wifi-cmd. in your case, the WiFi kernel modules are not loaded (this is the default), hence why you see no interface. the wifi-cmd will help with this. execute without arguments to see usage options.

cheers, hope this helps,

Hi Ivor,
The wifi tab in the setting page at the front end wasn’t there.
I worked out that the problem was a rogue space in the /etc/network/interfaces file. Now the wlan0 is configured.

However, this still doesn’t help with using a mobile bb dongle rather than wifi. I know that someone must have already done this. Any tips?

Does the shake need to be in stand alone mode to be able to access it directly (ie plug ethernet cable between shake and laptop, not using internet)? For example, if I wanted to configure it in the field.


hi jess,

no, you don’t need standalone mode to get a wifi dongle working.

i suspect that the problem is that the interface is named wlan1 and not 0. try specifying 1 in the /etc/network/interfaces file for the wlan interface and see if that doesn’t help things. this is on our radar to make more automated than it currently is.


Hi Richard,

Sorry, I was not clear with my previous questions:

  1. I am not trying to connect a wifi dongle - it is a data (mobile broadband) dongle, and I am trying to connect to 4G. Should the wifi be on or off for this?

  2. I am only seeing wlan0, and not wlan1 from iwconfig:

docker0 no wireless extensions.

lo no wireless extensions.

vethf1fbe79 no wireless extensions.

enxb827eb89f2f9 no wireless extensions.

vethf5b1161 no wireless extensions.

ztrfygcemb no wireless extensions.

veth2256d05 no wireless extensions.

wlan0 IEEE 802.11 ESSID:“SKY4D473”
Mode:Managed Frequency:2.412 GHz Access Point: A0:BD:CD:06:DF:B2
Bit Rate=72.2 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=70/70 Signal level=-37 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

enx0c5b8f279a64 no wireless extensions.
This is clearly my home wifi, but is this through the internal receiver, or the dongle?

  1. How do I configure it to connect via 4G rather than wifi? When I plug the dongle into my pc (with pc wifi off), it automatically connects to the internet using 4G. I believe that the drivers are already installed on the shake.

  2. A completely different question - if I want to talk to my shake directly through a pc by plugging the ethernet cable into my pc, does the shake first need to be in stand alone mode? I ask this because I cannot connect in this way, either using a web browser, or ssh via rs.local, or the IP address. Whereas I can connect using either of those methods and addresses via the internet (therefore I know that I have the correct IP).


Hello Jess, welcome to the community!

Since the dongle is a 4G data one, it is normal that in the first instance it will not appear from iwconfig.

Can you tell us the brand/model of your 4G data dongle? To have a better reference frame in looking for options.

In the meanwhile, you can try this, from your prompt:

sudo vim /etc/network/interfaces

and then, at the end, add the following lines:

allow-hotplug usb0
auto usb0
    iface usb0 inet dhcp

allow-hotplug eth1
auto eth1
    iface eth1 inet dhcp

then reboot the RasPi with the 4G dongle connected to it, and then do another iwconfig.

If you see something similar to this:

eth1     Link encap:Ethernet  HWaddr 00:1e:10:1f:00:00    
     inet addr:  Bcast:  Mask:  
     inet6 addr: fe80::21e:10ff:fe1f:0/64 Scope:Link  
     RX packets:348 errors:0 dropped:0 overruns:0 frame:0  
     TX packets:53 errors:0 dropped:0 overruns:0 carrier:0  
     collisions:0 txqueuelen:1000   
     RX bytes:144890 (141.4 KiB)  TX bytes:5435 (5.3 KiB)

then the dongle should be all right. In practice, the 4G stick has been configured as a fake ethernet port (eth1) and from there you should be able to get internet.

Also, there is a reference in the manual, here, if the above doesn’t work:

Regarding your last question, this page on the manual can be of help: