Config not showing up - Config messed up?

Dear Support

My shake R3EDD and my boom R489A have both updated to 0.16.
The shake is running fine, in the boom the config seems to be messed up.
My helicorder files are only 7 days back and I can’t open the config or action page. If i try to load the page, sometimes the action or config pages is showing up, but in the config page, fields are not acessible or do not show up correctly. Browser is the latest Firefox and Cache is cleared.
Any ideas what I can do?
Many thanks, Jochen, HB9DRT

hi jochen,

as a first look, can you send along your log files, perhaps something there might explain it.



Hi Richard

Thanks for the reply. I know how to download the logfiles, but did not found an upload button for my post. :upside_down_face:
RSH.R489A.2020-01-28T06_17_04.logs.tar (3.5 MB)
Stupid, just drag and drop …
Here’s the log…

@ivor I’m also having a similar kind of problem. First of all today our shake stopped working and then I came to know sd card is not working. I replaced the sd card with another shake which I’m not using. After our shake was online it automatically updated to 0.16 version but after the update config is not working and if I try to save the settings it goes to ‘Attempting to restart’ and forever loop. The log files are attached. RSH.R1983.2020-01-28T08_14_15.logs.tar (1.1 MB)

@ivor if you want me to do hard tweak from linux backend please send me the modified config file so that I can do that. Thank you!

Dear Richard

Any news? It is even getting worse and the mainpage is missing also values.

Can I do something as long the Boom is reachable? I can not physically access the Boom, as we have over 60cm of snow.
Any update scripts I could start via ssh?
Here is the latest log…
(4.5 MB)
Many thanks

After investigating the logs, it seems this is related to bad values in /opt/settings/config/config.json, specifically lat and lon. Can you confirm they are not null and if so fill in a value for them ( 0 is fine ).

A fix for this is coming as well.

Hi wlee

Thanks, that solved my “Empty Main Page” problem, Server Connection: not connected.
/config is still not working. After certain reload, reload, reload Config is showing up, but could not be saved.

Here’s the log.

RSH.R489A.2020-01-28T06_17_04.logs.tar (3.5 MB)

Many thanks

There is an issue with the current config page if the file /opt/settings/user/UDP-data-streams.conf does not exist. Try touch /opt/settings/user/UDP-data-streams.conf, refresh and see if you are still experiencing issues.

This and the lat/lon issues will be dealt with in an upcoming patch.

No, that did’t help. In my shake, there is also no /opt/settings/user/UDP-data-streams.conf. I also tried to cp the .tpl into a .conf file, but the same problem.
On the main page, Server Connection is still not connected.

Is there a way to do a kind of master reset?
Is it possible to copy certain folders from my working shake to the boom?

Many thanks

Count me in the the /config issue.

/config isn’t showing up for me on my boom. lat and lon are correct.
UDP-data-streams.conf was missing, but creating did not help. I tried rebooting after creating it. Still no help.

I also have a 3D and a 4D that do not have this issue.

The issue regarding the config screen on Boom devices has been found and fixed. It will be released in the upcoming patch as well.

My Shake already updated to 0.18, no issues found.
My Boom is still on 0.16 showing Server connection: not connected. Does this disturb the auto update process?
Release notes of 0.18 are not yet online, just for info.


I just rebooted the Boom and the device updated to 0.18 :slight_smile:
All seems to be working.
Had to reconfigure the sensor type to yellow/20 sec.
Static IP is working
Datacast contains two IP addressee: and What are they for? They are not in my boom.

Static IP had to be set two times, than it was stored.

So it looks, like all is working fine again…

Many thanks for your support and fix

Good morning Jochen!

They have been online since the update was released. Hit CRTL+F5 :slight_smile:

Is this a bug? Was it already configured this way and then it lost the configuration?



Yours, Branden

Hi Branden

Sorry, I already tried CRTL+F5, also two other Browsers, also CTRL+F5 in the Boom WEB IF which links to I only see ver.16, sorry.

Yes, 20 sec. yellow was configured before and was no longer configured after the upgrade.

The empty static IP field was empty, only on the Shake. On the Boom, it was fine.
After setting the IP address two times with two reboots, it was fine.

Now, all is looking fine :slight_smile:
Many thanks to all of you, for your support.


Try now. You are totally right. I forgot to push the changes. Fixed!

@ivor @wesleyv


Yepp, it works now :slight_smile:

1 Like