Can't keep server connected

I was running fine for months and months until the SD card died after a power outage, new SD card 32gb, formatted & loaded .19 several times as I had connection issues until I edited the dhcp.conf file and manually set the network settings. then I got connected and it was running for weeks until today I got an email that my station was offline, again it looked like network settings were lost.

So formatted card, again downloaded and installed .19, filled out name/location enabled data forward and it connected until I rebooted, then no server connect again. Interestingly if you go to general screen and say save and restart it connects again until the next reboot. I also will mention that trying to set a static I.P. does not work, after reboot the settings are gone.

I have attached logs from last reload without me under the covers changing anything, at the moment it is showing online but a reboot and it will not reconnect to the server againRSH.R0F73.2021-12-02T22_18_41.logs.tar (748.5 KB) .


Hello kps, welcome to our community!

Thank you for your detailed explanation and for posting the logs from your Shake, they were definitely helpful.

Could you please execute a reboot, wait for around 10 to 20 minutes without modifying the network configuration again, download the new logs and send them to me?

I would like to compare the ones you attached previously (with a working configuration) with the new ones (with a not working config) to try and see where the issue could be in a more precise way.

I know that putting the network config again will be a bother, and I thank you for your collaboration.

It’s no bother at all, thank you for looking at this. I did nothing but reboot, it did not reconnect to the server and here are the logs. I had wondered if the previous logs would go back far enough to show the failure, these should definitely have the error. Thanks. RSH.R0F73.2021-12-03T15_50_55.logs.tar (1.1 MB)

Thanks for the new logs.

Comparing the two, it seems, at least from this single reboot, that the DNS configuration is retained through the reboot itself. Both logs show the same line with the same DNS addresses (I will not post it here for privacy purposes).

Could you please reboot the Shake again, and then try the following procedure to see if it solves the connectivity issue?

Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Try unchecking the Forward Data box and, after ~30 seconds, recheck it. Then,click save and restart.

The station should now be able to connect again.

If it does, then this error is caused by a known bug that we are examining and that will (hopefully) be solved in the next Shake OS v0.20 release.

Following the steps it does reconnect, but it goes back to not connected at the next reboot. It’s like the OS is not ready for the shake code on the initial boot, and any restart (data or general) later connects fine. One other question, if I go into network and check static I.P… and set a address then save & reboot, if I go back in and look should I not see the box still checked and the address I selected in the field? mine is blank each time which makes me wonder if it took or not, I thought in previous code versions that the field was filled in and the box showed checked, am I mis-remembering? Thanks

P.S. well now I have broken it, by trying to set a static I.P. it will no longer connect after a restart, nor using your method.
RSH.R0F73.2021-12-03T20_14_55.logs.tar (1.2 MB)

Well, just a follow up. Now that I understand the mechanics of the problems and their interactions and the workarounds, I guess the thing to do is wait for the next update for a fix. Did a few reformats and installs and can say with certainty that setting a static IP now breaks server connect every time, so I have setup my router to force a static IP based on the mac instead. And any reboot breaks the connection also but just waiting a bit and doing any restart causes it to reconnect. So I will watch for offline warning emails to inform me a restart is in order.
Thank you for your time.

1 Like

hi kevin,

thanks for the detailed reporting. we are looking into this, first to recreate the problem, then to get it fixed.

apologies for the troubles,

No apologies required, I appreciate everything the Shake Team does in supporting the user community.


Stormchaser and kps:

I’ve been running my 1D RS for several years with very few issues. I monitor it daily with Swarm. Recently we had a planned power outage, so I powered it down through rs.local and then started it up again after the repairs were finished. When I reconnected with rs.local, I noticed that the Server Connection was disconnected, but ignored it since I could see everything through Swarm (connected locally).

I received an email from the Raspberry Shake Team informing me that my connection had been down for over three days. After poking around I realized that my unit was offline, looked on the forum and found this string. I tried the solution offered (" Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Try unchecking the Forward Data box and, after ~30 seconds, recheck it. Then,click save and restart."). That solved the problem and I am once again online and streaming.

Just wanted to let you know that I fixed the problem using your solution AND also to say thanks for the email informing me I was offline. Never would have known otherwise.

Great support and great hardware! Keep up the good work!!! :earth_americas:


I am seeing this problem as well, but also a lack of reconnection to the network on reboot from my RSnB. I have spent some time troubleshooting this, and itbis the same across 3 different routers, so fairly certain the Shake sometimes fails to connect to the network (RS.Local AND direct IP connect yields a blank page). I note that on reboot now there is a countdown of some sort when I connect a monitor. What is that for?

1 Like