Can't install rsudp

Hello, I am unable to get any conda besides miniforge to work. Is it possible to use miniforge instead or do you have any other ideas? I am on Raspberry Pi OS 32bit on a Raspberry Pi 4B.

Here is the full terminal:

matthew@raspberrypi:~/bin/rsudp $ bash
Looking for existing installation...
Starting install script.
Raspberry Shake UDP client installer v0.3
Ian Nesbitt, Raspberry Shake S.A., 2022
Please follow instructions in prompts.
Press Enter to continue...

This script will need to use or create a directory to store miniSEED data and screenshots.
Common choices might be /home/matthew/rsudp or /home/matthew/opt/rsudp
Where would you like the rsudp output directory to be located? You can use an existing one if you would like.
Press Enter when done (if no input is given, the script will use /home/matthew/rsudp):
No directory was provided, using /home/matthew/rsudp
Successfully created output folder /home/matthew/rsudp
Looking for conda installation...
Cannot find conda installation; will try installing miniconda3.
Found Linux environment on aarch64.
Install location: /home/matthew/miniconda3
Ready to download miniconda3
The download could be as large as 200 MB.
Press any key to continue or Ctrl+C to exit...

--2023-07-20 01:55:47--
Resolving ( 2606:4700::6810:8303, 2606:4700::6810:8203,, ...
Connecting to (|2606:4700::6810:8303|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 70489432 (67M) [application/x-sh]
Saving to: ‘/tmp/’

/tmp/      100%[========================================>]  67.22M  4.39MB/s    in 13s

2023-07-20 01:56:00 (5.10 MB/s) - ‘/tmp/’ saved [70489432/70489432]

Installing miniconda3...
Unpacking payload ...
./ 351: /home/matthew/miniconda3/conda.exe: Exec format error
./ 353: /home/matthew/miniconda3/conda.exe: Exec format error
Cleaning up temporary files...
Updating base conda environment...
/home/matthew/bin/rsudp/bin/ line 157: /home/matthew/miniconda3/bin/conda: No such file or directory
The script will now append a sourcing line to your ~/.bashrc file in order to
make activating conda easier in the future (just type "conda activate" into a terminal).
This line is: . /home/matthew/miniconda3/etc/profile.d/
Press Enter to continue, or type no and press Enter to prevent this...

Appending sourcing line to bashrc...
/home/matthew/bin/rsudp/bin/ line 194: /home/matthew/miniconda3/etc/profile.d/ No such file or directory
Activating conda...
/home/matthew/bin/rsudp/bin/ line 196: conda: command not found
ERROR: Anaconda install failed. Check the error output and try again.

I have got it working before but I have no idea why I can’t now

Edit: I just just notice it says ./ 353: /home/matthew/miniconda3/conda.exe: Exec format error so I have now switched over to the 64bit Raspberry Pi OS and it still says the same thing.

Trying to install Miniconda for aarch64 beforehand does not work either as I get

Unpacking payload ... line 359:  1885 Illegal instruction     "$CONDA_EXEC" constructor --prefix "$PREFIX" --extract-conda-pkgs

Hello Matt,

I remember something similar happened when I tried to install RSUDP on a Pi4 unsuccessfully. I think it was related to the different architecture between Pi3s and Pi4s that somewhat generated the error you are seeing. However, if you installed it before on a Pi4, something else could be in play.

I am not aware of a method to fix this, but I think there is already a ticket open on the main RSUDP GitHub page: Issues · raspishake/rsudp · GitHub You can add there your experience and see what the original developer thinks about it.

1 Like

Should I get a Raspberry Pi 3 instead for it?

As far as I know, Pi3s are fully supported (I have RSUDP running 24/7 on a 3B+), so, yes, I would recommend that as the fastest/easiest solution if you have that board available.

Okay, I just ordered one so hopefully it won’t take too long to get here. Thanks for the help!

I did come across what you said doing a ton of googling so I guess there just isn’t any way to do it for now


No problem at all!

Yes, it was a bit hard for me to find out the possible cause too, so I reverted back to a 3B+ that I had unused around the house. Hope you’ll manage without issues when the board arrives!

1 Like

Hi, i havent been able to resolve my problems with the rpi4, is there an OS that you recommend for rpi 3B+?

The standard Raspberry Pi OS (Raspberry Pi OS – Raspberry Pi) should be more than fine. Among all the options, I personally use the

Raspberry Pi OS with desktop and recommended software

from this page Operating system images – Raspberry Pi

1 Like

It arrived and the software installed without any issues at all!


That’s great to hear Matt! Enjoy!

Hi, is there any difference in compatibility between the 32-bit os and the 64-bit one?

Hello Matiro, I would go with 32-bit version, as it has never given me issues in the past. I never tried the 64-bit one, to be complete in my answer.

1 Like