Cannot Turn on Stand-Alone

I am attempting to use my RS 3 Model B in offline mode with a Windows PC, following the instcution here: Offline and stand-alone applications (like classroom demos) — Instructions on Setting Up Your Raspberry Shake.

First, when I tried to do the following, there is no option to turn on STAND-ALONE anywhere under http://rs.local/:

  1. Open the Raspberry Shake’s internal web frontend by navigating to http://rs.local/ >> Select Actions icon >> ACTIONS >> TURN STAND-ALONE ON;

The second option below requires to run Linux commands:

  1. Log in to your Raspberry Shake via SSH (How to access your Raspberry Shake’s computer via ssh) and run the following command:

Could anyone help me?

My guess: They changed the name on the “button”

I would try “Turn Off-Line Mode On” as being equivalent to stand-alone ???

Thanks, but that option is not displayed either. I see only three options there, REBOOT, SHUTDOWN, and CHANGE SSH PASSWORD.

Hello d_koba, welcome to our community!

Yes, as Philip indicated, the button text has been changed, and I thank you for notifying me about the inconsistency in the manual. It has now been corrected.

The fact that I find unusual is that you don’t have that option in the ACTIONS menú on the same page, as it seems to be some kind of bug. Have you tried to reboot/shutdown-restart your Shake to see if this operation makes the button “pop-up” again?

If it doesn’t, then you can just open any terminal on Windows, or MAC, or Linux, and type:

ssh myshake@rs.local or ssh myshake@ShakeIPAddress

You will be prompted for a password (your personal one, or, if you haven’t changed it, the standard shakeme) and, after that, you will be logged into the Shake OS.

At this point, you can directly execute:

rsh-stand-alone and then reboot.

With this command, the Shake will restart in Stand-Alone mode, ready to be used as you indicated.


The option of TURN OFF_LINE MODE ON is displayed when I opened rs.local on FireFox. On two different PCs, the option did not show up on Chrome.

1 Like

Thank you for the feedback d_koba, I will put this in a note for the software team, so that we can do more testing for when the next Shake OS version comes out, and see if we can fix this issue.

Glad that you managed to solve the problem!