Cannot connect to WWS server

Hi.

I’ve just noticed that I cannot connect to MyShake through WWS with Swarm.

The error I get is:
2021-05-18 02:47:15 ERROR - Error connecting to 192.168.4.74 192.168.4.74:16032 in WWSClient. (java.nio.channels.UnresolvedAddressException)

I have been able to connect in the past.

I am running on home network and my router has a recently upgraded system.

I rebooted my Shake but still cannot connect via Swarm.

I am attaching my log.

Thanks in advance for any advice.
steve
RSH.R2352.2021-05-18T18_40_28.logs.tar (3.2 MB)

Hello Steve,

Thank you for your logs. From them, I am seeing that your router seems to have assigned two different IP addresses to your Shake.

One is the one you are using now on WWS 192.168.4.74, and this is the second one: 192.168.4.42.

Have you tried connecting via WWS on SWARM using the second IP address?

Thanks for getting back to me!

I think I have fixed the 2 different IP addresses by plugging the ethernet cable into the unit. When I log into rs.local I see that it shows the IP address as Ethernet Local IPv4 : 192.168.4.42. I’ve also disabled Wifi on the Shake. Now the router only shows 1 IP address assigned to the unit.

When I try to connect using SWARM using 192.168.4.42 I am still unable to connect…

Thanks!
Steve b

Hello Steve,

It’s no problem at all, you’re welcome! Thank you for your further explanations, could you post here a screenshot of the WWS configuration screen on SWARM? So that we will not be doing a to and from asking for info and I will have everything I need.

Thank you.

Here is my WWS config screen from SWARM.

Thanks!
steve

Hello Steve,

I think that the issue is that you have two IP addresses in the first field, and this confuses SWARM.

Could you remove one of them, and leave only one instance of 192.168.4.42? All the rest looks good.

Thanks!

Just as you suggested. With one entry removed it works as it should. The second IP address entry must be a leftover from my mistake of leaving Wifi checked on in the rs.local configuration even though I was connected by cable. This caused the router to assign 2 ip addresses.

Thanks so much again!
steve

2 Likes

It’s no problem at all, you’re welcome!

Glad that we were able to solve the issue.