Brand New Shake Cannot connect to configure it

Brand new shake, received it yesterday, opened the box and plugged it in today. Can’t connect to it using a web browser like the instructions say.

Here is what I’ve done so far:

  1. Both LED on the shake’ss eithernet port light when a network cable is plugged into it.

  2. The network cable has signal. Plugged a laptop into the network cable going to the Raspberry Shake. Laptop can access the internet. Plugged cable back into Shake.

  3. When plugging the network cable into the shake, a green LED which next to the red power LED, flashes 4 times, twice.

  4. Tried connecting http://rs.local, http://rs.local:5000, and None worked.

  5. With the Shake powered off. Ran and arp-scan on the local network. Turned the shake on. Ran another arp-scan. Compared the results of the two scans. No difference. Appears the shake did not try to acquire an IP address. Confirmed this with the pfsense firewall DHCP server. No one asked for a new address.

  6. Removed and re-inserted the micro-sd card. No improvement.

NB: I do not have a micro-hdmi cable … yet.

Any ideas what else I can try.

1 Like

If the shake doesn’t get an IP for whatever reason, it has a pre-configured IP that it falls back to.
You can try connecting to that to inspect/copy the logs to see what is going on.

See: Discovery IP — Instructions on Setting Up Your Raspberry Shake


Thanks PhillipPeake for the info about the discovery-ip address. I tried the instruction but without success.

Entering: ssh myshake@rs.local’ fails with an error message that DNS cannot resolve ‘rs.local’.

Here is the setup:

  1. Direct cable between a laptop running Kali Linux and Raspberry Shake.
    – powered cycled Shake after connecting ethernet cable between laptop and shake
    – ethernet LEDs on both laptop and Raspberry Shake light up.
  2. Logged in to laptop as root
  3. entered ifconfig eth0 up
    – worked, confirmed by entering ipconfig with no arguments
  4. entered ‘ssh myshake@rs.local’
    – error message is: could not resolve hostname rs.local

After getting the DNS error, I tried apr-scan from the laptop:
– 'apr-scan -I eth0 --srcaddr=eth0.MAC.ADDR
– scan took about 5 min and found no other hosts on the network. The Shake did not respond any address in the range

NOTE: When doing an apr-scan the LEDs on the computer’s ethernet port flash. The LEDs on the Raspberry Shake do NOT flash.

– Tried a different ethernet cable. Same result, no improvement.


Q1: How does the name ‘rs.local’ get resolved to an IP address?

I understand how DSN works. There is a file which maps names to IP addresses. In the “Discovery IP” help page, there is no mention of setting that mapping file up. Its possible some “magic” has been added to DNS in the years since I’ve looked at. Which is why I’m asking the question if you know how the name ‘rs.local’ is resolved.


I did order a micro-HDMI cable but it will take time to be delivered.

Q2: Can you think of anything else I can try without the HDMI cable.




1 Like

The .local domain is (IMHO) a bit “iffy”, it is based upon Apple Bonjour protocol - which is a broadcast on the address 224.0. 0.251 and those systems participating respond. It obviously only works on the subnet to which you are connected. Also, being originally defined by Apple, Microsoft have been a little, shall we say, reluctant to fully implement it in a manner compatible with everyone else.

As far as I know, any modern Linux system works fine.

I am not sure that an HDMI cable is going to help, I don’t think the Shake OS has the desktop software.

You could mount the sd-card on another system and pull off the logs that way …

When @Stormchaser gets back on-line tomorrow morning (UK time) he will have some more specific advice. Probably to start by re-burning the SD card, but I am guessing that he will have some other things to try first, because they will probably really want to understand what is wrong - they want these to work out of the box, and so if any does not, they will want to understand why it has not.


Thanks Phillip, for tip about the ‘.local’ domain.

I’ve been running ‘tcpdump -i eth0’ on the laptop side since I saw your message about the Apple Bonjour protocol. It hasn’t returned any packets yet.

And yes, we’ll wait for Stormchaser, I’m not in a rush and if debugging this problem helps deliver a better product then I’m happy to be part of that.




Hello Ldya, and welcome to our forum!

Firstly, thank you for deciding to be part of our worldwide community. Now, let’s get your Shake working!

Thank you also for the extensive feedback and explanations that you have provided, especially the step-by-step tests that you have done. Can you please do the following for me, and test if, when turning on the Shake, the LED behavior follows what is listed here Technical Specifications — Instructions on Setting Up Your Raspberry Shake?

I have a general idea with your descriptions, but I would like to start from the booting process onwards.

As Philip said, the HDMI cable will not be of much help until you access the Shake and enable it manually (instructions on how to do so are here: How to turn on HDMI — Instructions on Setting Up Your Raspberry Shake). The HDMI output is disabled by default in our Shake OS as it is a resource-intensive application. However, if you wish to have a display output, you can check our ‘kiosk’ reference page: How to create a Raspberry Pi-driven Kiosk display — Instructions on Setting Up Your Raspberry Shake

I imagine you have also tried, but have you reset/rebooted your modem/router to see if that makes any difference in detecting the Shake? The fact that, however, you cannot see it in DiscoveryIP mode is unusual, but we’ll get there once these checks are done.

It is possible that a microSD card re-burn would solve all, but I would like to understand why this is happening first.

Thank you for your patience and collaboration.


The power up LED on my shake is NOT precisely as described in the link you kindly passed along.

Specifically, the green LED powers up as solid, flashes 4 times, twice then stays off permanently. The Ethernet LED both light and stay lit, the green one never flashs.

When the board powers up, the red, green, and blue LEDs are lit.

The steady state of the board is red, blue LED steady on. Green LED steady off, Ethernet LEDs steady on, both of them.

I did reboot the switch the Shake is plugged, tried different cables and tested the switch port. All okay.

Ran “tcpdump” for 8 hours on the Shakes Ethernet port. Shake never sent a single packet.

Thx for the heads up on the micro-HDMI. I had naively assumed a command line console with diagnostics messages was there if I could only see it. Nice to know it isn’t.

I’ll wait for further instructions, which I will assume are re-write the micro-SD. But I’ll wait for you to tell me that incase there is something else you’d like to try first.

I’ve recently installed V20 and hdmi is enabled by default on that, well at least console output, thank heavens as you are doing any sort of DIY build then the console is de rigueur.


Hello Ldya,

Thank you for the additional feedback; it’s exactly what I needed to understand your situation better. The fact that the green LED turns on, blinks for a bit, and then turns off indicates that an issue with the OS on the microSD card is likely.

Re-burning it is the fastest way to address this problem. You can download the Shake OS image from here: raspberryShake-public / Raspshake Sd Img · GitLab, while the instructions on how to install it (if needed) are here: raspishake-microSD-card-software-Instructions.txt · main · raspberryShake-public / Raspshake Sd Img · GitLab

If everything goes well, your Shake should now connect to the network and appear on your modem/router admin panel, and in your general LAN.

For anything else that you may need, I remain available.


After much trail and error, was able to get the shake working. Thank-you!

On the linked webpage under the instructions labeled, “Complete instructions are as follows”, these instruction did NOT work. They left the Pi green light flashing 4 “slow” pulses followed by 4 “faster” pulses. No booting, no traffic out the Ethernet port.

Under the section labeled, “Alternative Burning Method”, these instructions did work. .ie get the Shake OS file, use balenaEtcher to copy it to the microSD card, put the microSD card in the shake and boot. In less than 5 min the Shake was up and running.

One suggestion for improving the product, When testing the Shake before shipping it to your customers, stick a label of the Raspberry Pi’s MAC address on the outside of the Shake’s plastic cover.

Much time was spent figuring out which IP address DHCP assigned to the Shake. Without knowing the MAC address it takes time to eliminate machines until one eventually determines that NONE of active IP addresses on the network belong to the Raspberry Shake so the Shake must not have booted.

The DHCP server maintains a log of MAC <—> IP address. If the MAC isn’t present in the list then one knows right away the Shake never requested for an address. A label on the outside of the Shake with it’s MAC address would have made using the server’s list possible.

NB: the http://rs.local for resolving the Shake’s IP address works on Windows, even though the Bonjor protocol is an Apple standard. I didn’t know this and it is a clever way of doing it.

To the uninitiated, as the Shake boots, the green LED on the Pi is busy dancing on and off with lots of flickering. If when you apply power and the green LED is kind-of boring as the Pi is firing up. The Pi didn’t boot.


hello Ldya,

good to hear you are now up and running!

thanks for the excellent feedback and suggestions, we will definitely have a look. so many small incremental improvements start in the form of feedback like yours, we appreciate very much the thought and time taken to let us know your experience and how it could be made better.

enjoy your Shake!


1 Like