Blank screen on rs.local

I don’t seem to see the same issue I’m having in any other posts. I’ve connected a new Shake for the first time and have left it to update for a couple of hours now to see if this would resolve the issue but I’m getting the same blank screen. I see the upper blue bar with home page, the gear icon etc and the lower blue bar with icons to download Swarm or go to station view etc but the entire middle section is a blank white screen regardless of whether I’m on the Settings tab or the Actions tab. I’ve tried on both Chrome and Safari. I’ve tried on both my laptop and phone and get the same result. I’ve also loaded using the IP address with the same result

Hello mceweng, welcome to our community!

Your issue resembles something that I have seen before, but not quite the same. Have you tried to do a hard refresh (with Ctrl+F5 or Mac equivalent) to see if this clears the cache appropriately and the content of the page appears?

If you have already tried, or it hasn’t worked, can you try to shut down the Shake, wait for a couple of minutes, then turn it on again, and check that its LED behave as reported on this page?

https://manual.raspberryshake.org/specifications.html?#led-behavior

Thank you!

Thank you for that advice. I should have thought to do a restart on the device. It worked perfectly.

2 Likes

OK, now I’m trying to set up my RS&Boom for the first time and I’m having the same problems as before except this time if I use the rs-local address, I’m seeing the Raspberry Shake Config on the internet tab but the entire screen is blank, I’m not even getting the header and footer bars. If I try the IP address instead, I am getting a ‘this site can’t be reached’ error message. I’ve tried rebooting my computer with no luck and I’ve tried unplugging and re-plugging in the unit. Nothing is working. I had turned off and removed my other Shake prior to trying to setting up this one. All the lights are behaving as expected.

Hello mceweng,

It’s great to know that the other Shake is now working as espected!

For the RSBoom, have you tried to shut down the Shake, turn off the modem/router, wait for a bit, turn on the modem again, wait until there is internet connection, and then reconnect the Shake and turn it on?

Does this kind of reset of the local network works?

Naturally, make sure that the IP address of the new Shake is not the same of the old one, but I am sure you have already checked this out.

Hi Stormchaser,

Thank you so much for trying to help on this issue.

I have tried resetting the router and there was no change in the outcome. And yes, the IP address is different than the first.

Any other thoughts?

No problem at all mceweng, I’m here for this too!

Yes, let’s try to see if you can connect directly to the Shake bypassing the blank page you are seeing. If we can get the logs I could understand better what may be happening.

Can you try to open a Command Prompt and execute:

ssh myshake@rs.local or ssh myshake@shake_local_IP_address

The password, since I don’t think you had the chance to change it, should be shakeme (the default one).

If you can successfully connect in this way, can you then try to download a program called FileZilla and navigate to the

/opt/log

folder, download every file that is in that folder, zip it into a compressed archive, and send it to me?

Instructions on how to connect to the Shake via FileZilla are here on our manual: How to download your data — Instructions on Setting Up Your Raspberry Shake

I’ll leave also an image of a dedicated profile setting for your convenience:

image

If rs.local is not working in the host field, then replace it with the IP address of the Shake.

Hi Stormchaser.

I was able to access the shake using the command prompt as you instructed. The last line of code I saw once it connected ended with ‘opt $’. I downloaded and connected the Shake on FileZilla but nowhere in the directory do I see a directory labelled ‘opt’. Just ‘myshake’ which appears to be empty.

Hello mceweng,

Yes, I can see that you are successfully connected to your Shake.

If you double click on the top folder of the Remote Site section (the one above home, with only a / as a name) a list of new folders should appear in the window below.

Among them, you will be able to find the /opt folder, and from there you can navigate to the log folder and download all the files.

Hi Stormchaser.
Thank you for that info. I’ve found the opt/log folder but it is showing as empty

image0.jpeg

Hello mceweng,

Thank you for this second screenshot, and sorry for the delay in answering you. We had a couple of issues with our services yesterday that took a bit to be solved by our team.

The fact that both these two folders appear blank shows that there is something wrong going on with the microSD card. Possibly, some files may have been corrupted, or some process is not working as it should to generate the logs (and create the issue with rs.local/ blank screen.

I recommend then to re-burn the microSD card following these steps:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

After you have done this sequence, please wait for the Shake to re-download the new operating version so everything will be updated to v0.19. It should not take long and, at the end of the process, hopefully, the rs.local/ page will appear again normally.

The actual v0.19 image is being processed these days and will be uploaded soon. So, if you want to wait and download that one directly, you can do that too.

Thank you for your collaboration on this.

1 Like

Sorry Stormchaser, I haven’t had time to try this solution yet but I hope to get to it in the net day or so. I’ll let you know how it works out.

2 Likes

No problem at all mceweng, do it in your own time!

Hi Stormchaser. I tried to use the links you sent to download the new image and instructions from GitLab and neither links work. I’m taken to a 404 error page not found

1 Like

I found where to download the image off the Raspberry Shake site and I’ve formatted the microSD, which is 8GB but its only releasing 65MB.

1 Like

Thank you for notifying me of that link error mceweng, I have now corrected it.

Then you will have to delete all the partitions that are inside the microSD with some tool (if you are using Windows I recommend this: Overview of Disk Management | Microsoft Docs) and then format it again. In this way, you will have the entire 8GB available to use.

That worked for me. It’s up and running now.

Thanks

2 Likes

That is great to hear! You’re welcome!

Enjoy your Shake!

Just wanted to say that I had this same issue, followed the steps and I am back up and running. Thank you.

1 Like

Happy to help! And thank you for the feedback rbalik.