Avoid or filter out occasional spike or glitch?

#1

Below is a snippet of Python code that uses the ObsPy library to access, low-pass filter, and display three hours of data from one of my R-Shake devices. The lowpass filter is needed to reduce the traffic noise, but some spike-glitches which happen at irregular times are relatively huge. Ideas?
There are also some gaps with just plain missing data, I assume due to my internet dropping out, but I think that is a separate issue.

from obspy.clients.fdsn import Client
from obspy import UTCDateTime

client = Client(base_url='https://fdsnws.raspberryshakedata.com/')
starttime = UTCDateTime("2019-05-06 21:00:01")
endtime = starttime + 60*60*3
wave1= client.get_waveforms('AM', 'RF7DC', '00', 'SHZ', starttime, endtime)
wave1.filter("lowpass", freq=0.5, corners=4)
wave1.plot(type='dayplot',outfile='190506_21H_f_RF7DC.png')

For reference, below is the same dataset without the low-pass filter. The glitches are smaller, but the local road traffic noise (mostly above 5 Hz) is more prominent.

#2

Yes, I get these spikes too, as shown in attached plot, which shows three that occurred over a few minutes.

I’ve been looking at how to eliminate the spikes.
The trouble is that they are persist over several seconds and their energy is spread over a wide frequency band. Also, they are not too dissimilar from EQ waves, though the human eye (a superb instrument) can distinguish them quite easily.
The shape of the spikes is quite similar to Daubechies-type mother wavelets and I’ve been trying to use OWT (orthogonal wavelet transformation) to isolate them, so far without success.
In the meantime, I’ve found that eye-ometer followed by excision is the best method.

#3

BTW, I use Matlab for my analysis, but there is a wavelet toolbox in Python called pwt.

#4

Buenas noches.

Are you guys using the RPi’s built-in Wifi?

If so, this is the reason for the spikes- the wifi module generates big RF spikes that throw the analog circuit for a whirl.

If not, then perhaps Wifi is still enabled. You can check by downloading the log files from the Raspberry Shake’s web frontend and then reviewing myshake.out.

Another possibility is that you are installed very close to a source of RF.

#5
WiFi Info
--------------------
Kernel modules loaded : NO
           Enablement : OFF

Thanks Branden. Both my R-Shake units use wired ethernet. Above text appears in both “myshake.out” files from the two devices, so I assume this means there is no wifi active. One is in the woods out back, and the other is in the front yard but underground, so I’m hoping there isn’t much RF immediately nearby.

#6

WiFi Info

Kernel modules loaded : YES
Enablement : ON

I guess this means wifi’s on, yet I use ethernet. How do I turn wifi off?
The station is at our beach cottage - no cars, no cellphones, only the fridge and the RS have power when we’re not here.

#7

hi there,

default setting is that WiFi should be OFF, unless explicitly requested to be ON. not sure if it was ever on in the past and then didn’t get turned off? in any case, there are a couple of ways to turn it off:

  1. via the front-end, proceed to SETTINGS::NETWORK::WIFI SETTINGS. if WiFi is ON, the checkbox should be checked “Connect to WiFi”. Turn this off and click the button.

  2. if #1 is not true (“Connect to WiFi” is not checked), then log in to the unit and navigate to the directory /opt/settings/user and edit the file enable-wifi.conf. change the last line / setting to OFF from ON and reboot the unit

WiFi will then be turned off and your spikes will be forever in the past.

cheers, let us know how it goes,

richard

#8

Richard

I’ve turned it off, but I’m still getting spikes.

Cheers
Derek

#9

Derek and John:

Buenos días!

Interesting. Please send photos of your installations, especially the cables.

Thank you and have a great weekend!

From Panama,

#10

hi tideman,

please send your log files along, thanks.

richard

#11

I see the glitches on both my systems. Here is the one that’s underground:

The lead-in cable is a CAT6 direct-burial type. Inside the wood box under the brick weight is just the geophone sensor, the Shake board mounted on a Pi-Zero, USB cable, and 5V power wires that are soldered to to the Shake board. The geophone is clamped to the plywood case using 0.041 stainless steel wire, twisted tight. The case sits on three leveling screws, which rest on the concrete pad.

#12

Here are the log filesRSH.RC144.2019-05-11T09_57_00.logs.tar (1.5 MB)

#13

Hi Derek and John:

I am no sure of the origin of your spikes.

@TideMan - wow! You see a LOT of earthquakes on your Shake.

Yours, Branden

#14

The other night we were watching TV and a 3.2 hit us, but it only seemed to rattle the rafters. Then 2 minutes later we got another one. And again 10 min later. The epicentres were a few hundred m from the RS. They need to be >4.5 to worry us.