Android app crashes on Galaxy Fold 3 running Android 12

Hello, I’m having trouble using the app to see data from my shake. I downloaded the app logged in and it worked great. The 2nd time I opened the app, when I clicked on my station, the app crashed as soon as it rendered the data. Then from the third time opening the app onward, it says no station found under my stations. The only way to get it to work again was to uninstall and reinstall the app, but the problem comes back as soon as you open the app a second time.

The issue only happens when I try to view it from the first tab, if I go to the station’s tab and search for my station I can see the data perfectly fine.

Update: I tested it on my iPad and it has the exact same issue.


Hello kxd, welcome to our community.

Thank you for your feedback on this unusual behavior from our ShakeNet App. I’ve tried to replicate the issue on my Android 12 phone, but without success, so it is possible that there is something specific to the GF3 model that is causing the problem. And, if it is happening on an iPad too, it is also possible that there is a bug that needs to be fixed somewhere.

Nonetheless, I have opened a ticket for our app team, so that they will know where and what to look for. I will update you as soon as I have news from their side.

Thank you for your patience in this.

I am brand new to the community, but the app behaves in exactly the same way on my Samsung Galaxy S10/ Android 12.

First login after installation seems to work fine. Second time I open it, it crashes. Any other time I open it, my station is no longer found/listed…even on the stations tab. The web site shows my station to be operating as expected.

Is there any updates planned for the application, specifically for Android?


Hello rflancher, welcome to our community, and thank you for reporting these issues to us.

We are aware of them and our App team is working on releasing a fix as soon as possible. I will add your report to the open ticket so that they are aware of it, and I will update you when I have news from the team.

Hello kxd and rflancher,

The team has updated me, and the issues should have been solved with the latest App version (v1.4.8).

If you haven’t already, please download it and you can start using our ShakeNet App again. Thank you for your feedback that helped us in fixing this.

Just tried it and its working great! Thanks.


It seems to be working for me now as well. Thanks for the update!


That’s great to hear from you both!

Thank you again for having brought this to our attention.