'activate' is not a conda command. Keeps popping up. What should I do?

(I wrote it in Google translation.)
I installed rsudp on the raspberry pi
When I try to connect to a port or run a raspberry shake, I get the following error:

Error: ‘activate’ is not a conda command.
Did you mean “source activate rsudp” ?

What should I do?

Hello sele, welcome to the community!

Let’s see first if the installation works as it should. From the command prompt of your Raspberry Pi, can you run:

source activate rsudp (or conda activate rsudp if you installed it with anaconda)

and then


This will activate the testing mode, which will display a simulated seismograph for a certain amount of time. If this works, then we can proceed forward with your problem.

Thanks for any help.
I did what I told you
Error: could not find environment: rsudp
Appears. I also installed the rsudp file properly. Why is this?

It is no problem.

If that appears, it seems that the rsudp environment was not installed properly, otherwise you would have seen something similar to this:


Naturally, this is from Windows, but the behaviour is similar.

What you can try to do before trying to reinstall everything, is to tell your operating system where to find Anaconda, with this command:

. $HOME/berryconda3/etc/profile.d/conda.sh

where $HOME is the home directory of the current user.

After this, you should be able to run conda activate rsudp, and then launch the client with the rs-client command.

I also give you the link to the “How to run RSUDP” section of our documentation: 4. Running rsudp — rsudp documentation

Thank you for your very kind answer!
Then, when reinstalling, can I delete the rsudp file and reinstall it?

1 Like

No problem at all!

You can do that, but it’s better to try the conventional way first. From your Raspberry Pi prompt command, execute:

sudo dpkg -l

which will give you the list of all the packages installed in your Raspberry Pi. RSUDP should be among them. Then you do:

sudo apt-get purge rsudp

to fully remove the package, and:

sudo apt-get clean rsudp

to clean up everything. After this, reboot the system and reinstall RSUDP again. This is the relative page on our manual: https://raspishake.github.io/rsudp/installing.html

If you cannot find RSUDP in the package list, then there has been indeed some installation error. You can manually search for each folder with the same name and delete it. If you want to be sure, and you don’t lose anything, I would suggest just to re-burn the microSD card with a clean Raspbian OS.

If you decide to re-burn and re-start with a clean OS, remember to install Anaconda (as indicated in the instructions) before installing RSUDP.

Thank you for always good answers! I tried the answer and installed rsudp through the root account, but I got the following error. What should I do in this case?

Activating rsudp environment…
Success: rsudp environment activated.
Installing rsudp…
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Processing /home/pi/rsudp
Collecting obspy (from rsudp==1.0.1)
Downloading https://files.pythonhosted.org/packages/b8/8c/eef47074a1884c73bc4f2ba7b2961a79fc54952edadeff4b998de86dcb20/obspy-1.2.2.zip (24.7MB)
44% |██████████████▎ | 11.0MB 65kB/s eta 0:03:30Exception:

Traceback (most recent call last):
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_vendor/urllib3/response.py”, line 331, in _error_catcher
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_vendor/urllib3/response.py”, line 413, in read
data = self._fp.read(amt)
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_vendor/cachecontrol/filewrapper.py”, line 62, in read
data = self.__fp.read(amt)
File “/root/berryconda3/envs/rsudp/lib/python3.6/http/client.py”, line 449, in read
n = self.readinto(b)
File “/root/berryconda3/envs/rsudp/lib/python3.6/http/client.py”, line 493, in readinto
n = self.fp.readinto(b)
File “/root/berryconda3/envs/rsudp/lib/python3.6/socket.py”, line 586, in readinto
return self._sock.recv_into(b)
File “/root/berryconda3/envs/rsudp/lib/python3.6/ssl.py”, line 1009, in recv_into
return self.read(nbytes, buffer)
File “/root/berryconda3/envs/rsudp/lib/python3.6/ssl.py”, line 871, in read
return self._sslobj.read(len, buffer)
File “/root/berryconda3/envs/rsudp/lib/python3.6/ssl.py”, line 631, in read
v = self._sslobj.read(len, buffer)
socket.timeout: The read operation timed out

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/basecommand.py”, line 141, in main
status = self.run(options, args)
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/commands/install.py”, line 299, in run
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/resolve.py”, line 102, in resolve
self._resolve_one(requirement_set, req)
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/resolve.py”, line 256, in _resolve_one
abstract_dist = self._get_abstract_dist_for(req_to_install)
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/resolve.py”, line 209, in _get_abstract_dist_for
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/operations/prepare.py”, line 283, in prepare_linked_requirement
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/download.py”, line 836, in unpack_url
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/download.py”, line 673, in unpack_http_url
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/download.py”, line 897, in _download_http_url
_download_url(resp, link, content_file, hashes, progress_bar)
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/download.py”, line 617, in _download_url
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/utils/hashes.py”, line 48, in check_against_chunks
for chunk in chunks:
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/download.py”, line 585, in written_chunks
for chunk in chunks:
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/utils/ui.py”, line 159, in iter
for x in it:
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_internal/download.py”, line 574, in resp_read
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_vendor/urllib3/response.py”, line 465, in stream
data = self.read(amt=amt, decode_content=decode_content)
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_vendor/urllib3/response.py”, line 430, in read
raise IncompleteRead(self._fp_bytes_read, self.length_remaining)
File “/root/berryconda3/envs/rsudp/lib/python3.6/contextlib.py”, line 99, in exit
self.gen.throw(type, value, traceback)
File “/root/berryconda3/envs/rsudp/lib/python3.6/site-packages/pip/_vendor/urllib3/response.py”, line 336, in _error_catcher
raise ReadTimeoutError(self._pool, None, ‘Read timed out.’)
pip._vendor.urllib3.exceptions.ReadTimeoutError: HTTPSConnectionPool(host=‘files.pythonhosted.org’, port=443): Read timed out.

Something went wrong.
Check the error output and try again.

And when I removed rsudp and used the root account, I got the following error. How do I fix this? /root/.config/rsudp/rsudp_settings.json is not accessible anyway.

root@raspberrypi:~# cd rsudp/
root@raspberrypi:~/rsudp# bash unix-install-rsudp.sh
Looking for existing installation…
Found anaconda at /root/berryconda3
rsudp environment exists at /root/berryconda3/envs/rsudp
Starting update script.
Raspberry Shake UDP client updater v0.2
Ian Nesbitt, Raspberry Shake S.A., 2019
Press Enter to continue…

Could not find a settings file at /root/.config/rsudp/rsudp_settings.json
Please copy your settings file there and re-run this script.

Hello sele,

It seems that the system is a bit jumbled up. What I would advise doing is this:

If you encounter an error during any of these steps, please stop and tell me what it is, so we can solve them as they come, and go forward.

Hello! Thank you so much for continuing to respond!

I am trying to install anaconda as it is on this site, but I am getting the following error: “https://ubuntu-mate.community/t/how-to-install-anaconda-python/17844

root@raspberrypi:/home/pi# cd ~/Downloads
bash: cd: /root/Downloads: No such file or directory
root@raspberrypi:/home/pi# bash Miniconda-latest-Linux-armv71.sh
bash: Miniconda-latest-Linux-armv71.sh: No such file or directory
root@raspberrypi:/home/pi# cd ~/Downloads/
bash: cd: /root/Downloads/: No such file or directory

I don’t have to try several methods, what should I do?


This is probably due to the fact that there is no ~/Downloads folder already created at that adress, and thus the system doesn’t find it.

It has probably to do with the fact that you are looking for it from the /home/pi folder, while if I remember well the Download folder is in the root folder.

By executing this command:


and then


you will be able to see what’s inside the root@raspberrypi. For example, my results are:

Bookshelf Documents Music Public Templates
Desktop Downloads Pictures Videos

And here it is the Downloads folder we need.

So, from root@raspberrypi (and not from root@raspberrypi:/home/pi#) you should be able to do:

cd Downloads

and then execute the file. However, even if you don’t have or cannot find the Downloads folder, you can download the file with wget in any folder you want, by going into that folder and then:

wget http://repo.continuum.io/miniconda/Miniconda3-latest-Linux-armv7l.sh

and then continue the installation as described in that page.

Hello! Thanks for continuing to help!
I did what was written above, but this error pops up and I ask again.

Installing berryconda3…
ERROR: File or directory already exists: /home/pi/berryconda3
If you want to update an existing installation, use the -u option.
Cleaning up temporary files…
Updating base conda environment…
/home/pi/rsudp/bin/unix-install.sh: line 155: conda: command not found
Source line already exists in /home/pi/.bashrc
Activating conda…
/home/pi/rsudp/bin/unix-install.sh: line 194: conda: command not found
ERROR: Anaconda install failed. Check the error output and try again.

What should I do in this case?

Hello, no problem at all!

Thank you for the report, it seems that this berryconda3 is creating a problem, getting mixed with the normal Anaconda package. I tried to replicate your issue with my Raspberry Pi but I wasn’t able to.

Unfortunately, I don’t know the berryconda3 package, and thus I cannot help in telling what is exactly the problem.

If you want, you can write to sales [at] raspberryshake.org to ask a quote for paid support, since this is outside my knowledge and the sphere of free Technical Support.

Thanks for continuing to answer my questions! Fortunately rsudp installation was successful! However, I couldn’t connect to http://rs.local, so when I entered the rs-client command, the following result appeared.

Qt import failed. Trying Tk…
detail: No module named’PyQt5’
2020-11-14 11:32:59 [Main] Logging initialized successfully.
2020-11-14 11:32:59 Using settings file: /home/pi/.config/rsudp/rsudp_settings.json
2020-11-14 11:32:59 Output directory is: /home/pi/rsudp
2020-11-14 11:32:59 [Init] Initializing.
2020-11-14 11:32:59 [openSOCK] Opening socket on localhost:8888 (HOST:PORT)
2020-11-14 11:32:59 [Init] Waiting for UDP data on port 8888…
2020-11-14 11:33:09 [Init] ERROR: No data received in 10 seconds; aborting.
2020-11-14 11:33:09 [Init] Check that the Shake is forwarding data to:
2020-11-14 11:33:09 [Init] IP address: Port: 8888
2020-11-14 11:33:09 [Init] and that no firewall exists between the Shake and this computer.
Traceback (most recent call last):
File “/home/pi/berryconda3/envs/rsudp/bin/rs-client”, line 11, in
File “/home/pi/berryconda3/envs/rsudp/lib/python3.6/site-packages/rsudp/client.py”, line 475, in main
run(settings, debug=debug)
File “/home/pi/berryconda3/envs/rsudp/lib/python3.6/site-packages/rsudp/client.py”, line 158, in run
File “/home/pi/berryconda3/envs/rsudp/lib/python3.6/site-packages/rsudp/raspberryshake.py”, line 173, in initRSlib
set_params() # get data and set parameters
File “/home/pi/berryconda3/envs/rsudp/lib/python3.6/site-packages/rsudp/raspberryshake.py”, line 221, in set_params
data, (firstaddr, connport) = sock.recvfrom(2048)
File “/home/pi/berryconda3/envs/rsudp/lib/python3.6/site-packages/rsudp/raspberryshake.py”, line 102, in handler
raise IOError(‘No data received’)
OSError: No data received

Looks like a firewall problem. Should I install a firewall?

Good morning Sele!

As I made clear via direct message with you yesterday, we provide rsudp, as is, and have done as much as possible to make the installation easy and hassle-free. We do not support setting up python environments.

If you would like additional technical support, we can provide it for a fee. Please write us at sales [at] raspberryshake.org if you are interested in a quote.

Thank you for your support and have fun Shaking!

Yours, branden

Thanks for sending me a message

I install and run rsudp, but it keeps getting stuck.
I keep getting the same error even after trying the contents of 6. Troubleshooting rsudp — rsudp documentation. What should I do?

2020-11-30 06:45:34 [Init] ERROR: No data received in 10 seconds; aborting.
2020-11-30 06:45:34 [Init] Check that the Shake is forwarding data to:
2020-11-30 06:45:34 [Init] IP address: Port: 8888
2020-11-30 06:45:34 [Init] and that no firewall exists between the Shake and this computer.