4D Offline no response to SSH

Hi, My 4D if Offline I have solid Blue and Red lights, and blinking yellow, the LED on the network card is blinking but I can’t get any IP address assigneded to it, I have tried direct connection from a computer with IP address of and subnet of but I get no response from Ping, I also have installed a new SD card Kingston Digital 8GB Micro SDHC UHS-I Class 10 Industrial Temp Card and Burned new image and https://gitlab.com/raspberryShake-public/raspShake-SD-img/tree/master but it did not help

Hi @QC91, try connecting the Shake to a router and using Fing on your phone to find the IP. Also I believe your subnet should be, but this is typically a more difficult way of connecting than the router method.

Hi, @iannesbitt I setup dedicated Netgear router and used Fing but no 4D Shake is not detected I also tested multiple Ethernet cables, I also noticed amber lights on the Ethernet router indicating 100 Mbps or 10 Mbps and the lights turn off of about 30 seconds, seems to be a problem with 4D Ethernet

@QC91 is there any way you can remove the new SD card and zip the contents of /opt/log on the root partition of the drive and attach them here? It will require an operating system that can read ext4 file systems.

@iannesbitt I only have Windows 10 Pro, I have DiskInternals Linux Reader heres a screenshot can’t find /opt/log

Hi, I think I got the files here is zipFiles.zip (885.3 KB)

@iannesbitt I burned a new SD Card it back up but My passwords it not working I’m trying to http://manual.raspberryshake.org/hacked.html?highlight=password can’t find


I’m looking via DiskInternals here is a screenshot of all the folders

Hi @QC91, in that screenshot, shadow would be in the etc folder.

Thanks for the help trying to open the file in ubuntu linux but keep getting permission denied

Hi @QC91, if you have access to Ubuntu, can you try doing sudo nano <file location>?

sudo will give you root user privileges, and you should be able to both view and edit /etc/shadow.

BUT make sure you’re editing the file on the SD and not the /etc/shadow file on your Ubuntu machine.

@iannesbitt thanks I noticed there are 2 files named shadow is this normal ?

There should be one /etc/shadow file on the SD card and one /etc/shadow file on Ubuntu, is that what you mean?

@iannesbitt I’m seeing 2 shadow files on the SD card

It is impossible for there to be two files of the same name in the same directory. Most likely one is named shadow and one is named shadow-. This is normal. You are looking for the one named shadow.

Thanks for the clarification, On the sudo nano the path I see to SD Card is /media/ubuntu/3598ef8e-0…1-f24cf61dff1d/etc/shadow I’m trying sudo nano /media/ubuntu/3598ef8e-0…1-f24cf61dff1d/etc/shadow but cant opened the file

Can you post the error you’re getting?

sure its Could not open the file “/media/ubuntu/3598ef8e-0…1-f24cf61dff1d/etc/shadow”. You do not have the permissions necessary to open the file. here are few screen shots

Can you try running the following commands:

cd /media/ubuntu/3598ef8e-09be-47ef-9d01-f24cf61dff1d/etc
sudo nano shadow
1 Like

@iannesbitt thanks you for all the help it worked :smiley: