V18 update problems. Updated SWARM not downloaded

My system did it’s automatic update a couple of days ago and I just checked a coupe of things that indicate that it did not go smoothly. The system is running V0.18 ok but other things don’t look right.

When I try to download the updated copy of SWARM I get a 404 error (page not found). The URL is: http://rs.local/download/SWARM.zip. I assume the old copy, which was there before, was deleted and the new version never made it. The update log indicates that a download of SWARM 3.0.1 was started but the message (below) says that something went wrong:

" End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive."

I have uploaded a copy of the log files.RSH.R6B6E.2020-02-21T10_22_02.logs.tar (2.7 MB)


sorry for the troubles. turns out that the USGS updated the lastest version of SWARM for download from 3.0.1 to 3.1.0 and removed the previous version, so the updater finds nothing to download and fails the rest of the process.

please find attached a helper program which will download the latest version for you. copy this to the /tmp directory on your shake and execute the following sequence of commands:

> sudo mv /tmp/swarm-fetch /usr/local/bin
> sudo chmod a+x /usr/local/bin/swarm-fetch
> swarm-fetch 3.1.0

after the download completes, the zip file will be generated and will again be available for download from the front-end configuration interface.



swarm-fetch (12.2 KB)


Thanks, much better now. :wink:

1 Like

This solved my SWARM download problem I reported right after v18 came out as well…

1 Like

Hello, I just received and got my unit online today. I need to use this solution so that I may download swarm but I don’t know how to access and copy files onto the Shake from my mac either using Chrome or terminal (I’m terminal/bash illiterate, sorry). Is there another way I can download swarm so that it is pre-configured to my unit? Or is there a list of instructions to help me copy the appropriate files onto the Shake?

You can use FTP. I use FTP to archive my files each day as the SD card has a limited capacity. There is a Filezilla client for Mac’s (https://filezilla-project.org/download.php?platform=osx). To enable FTP on your Pi you will need to install an FTP server. I cannot remember if the standard image already has one installed so check first. (run “apt list --installed” from a terminal to check). I use vsftpd which is fairly easy to set-up. The popular alternative is “proftpd” - https://howtoraspberrypi.com/setup-ftp-server-raspberry-pi/

I hope this helps

1 Like

I have added a pinned post with multiple solutions for the problem you are experiencing @Danielle.

As mentioned above, this will be fixed in our next OS version, but until then please find solutions here:

If you have issues with adding the data sources as described in that post please let us know.

Thanks. I still haven’t quite figured out how to get the script onto the Shake without physically pulling the card out, which I don’t really want to do. Connecting with filezilla, even with ssh protocol isn’t working for me, and putting an ftp server onto it is more than I need at the moment. I’ve downloaded the new SWARM from the USGS website and the newest javasdk, but running either it isn’t working - no surprise, as I’m sure there is a set-up factor I’m missing. If filezilla will work - in manual mode to upload the swarm-fetch script - I could sure use exact instructions to get it to work.

Let’s start here, because running Swarm should “just work”. On your Mac, open up a Terminal window. If you unzipped Swarm to your Downloads folder, type this:

cd ~/Downloads/swarm-3.1.0
bash swarm.sh

What do you see now?

It opened Swarm! Yay! (It was in my Applications folder, but the "cd ~/Applications/swarm* didn’t get me there. For some reason I had to take out the tilda.

Ok, I see where I need to add the new data source (red star) and now I just need the information, I think.

That’s probably because the main Applications folder on Mac is confusingly not in your Home folder (which is shortened to a tilde, hence ~)

Sure, see bullets under 2b. in this post: