Station online but no server connection

Long time shaker. My site when down some time ago, and I simply did not have time to check into it. I’ve now discovered that it was a corrupted and dead SD card. I’ve installed a new image on a new SD card, and the shake is back up and running.

As best I can tell through troubleshooting, it should be sending data to the servers, but the Server Connection shows as Not Connected. Data Producer and Consumer are both ON, and I can see data streaming in via seedlink on my seiscomp system. It just doesn’t seem to be connected to the RS Server. Any suggestions?

I have confirmed that data forwarding is enabled, and I have made sure the DNS is not a problem (I had this in the past). The DNS server is manually configured to and it can resolve DNS without issues (ie, can ping web servers). I’ve also checked there are not any conflicting settings in /etc/dhcpcd.conf.

The station is RC2BF.


Hello Andrew, welcome back to the community!

I’m happy to hear that your Shake is up and running again! Let’s see what we can do to solve the issue you are having.

Thank you for all the details you have provided. Could you download the logs from the Shake and post them here? Instructions on how to do so are on this page: Please read before posting!

As a solution for your problem, could you please reboot the Shake and then try the following procedure to see if it solves the connectivity issue?

Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Make sure that the Forward Data box is checked, and then click Save and Restart.

The station should now be able to connect again.

If it does, then this error is caused by a known bug that we are examining and that will (hopefully) be solved in the next Shake OS v0.20 release.

Thank you for your cooperation.

Hi @Stormchaser,

Ok, logs attached.

I sort of did what you said. I didn’t fully reboot the Shake, but rather, went to the Data Tab, and confirmed that the “Forward Data” Check was selected. I then de-selected the data-forwarding checkbox, and hit “Save and Restart”. (As an aside, is the restart here just a WebServer or Service restart? It doesn’t look like the whole Pi is rebooting).

After it came back up, I went back and selected “Data Forwarding” checkbox. I hit save and restart again. This time when it came back up, it shows that it is connected.

Perhaps this is the bug you are referring to that will (hopefully) be solved in v0.20?


RSH.RC2BF.2022-01-05T16_53_54.logs.tar (1.3 MB)

1 Like

Another follow up for you.

Is it just the “Server Connection” that doesn’t show as enabled, but the data is actually being sent to the server still? The reason I ask is that in looking at the Raspberry Shake Dataview Beta page (RS DataView BETA), if I go to yesterday’s date, or even the day before, for my station (RC2BF), there is data there. Has it back-filled already (that is fast!!), or is it accessing data in real time from my shake, or was it just the status screen that showed no connection, but in fact the data was flowing in the background.


1 Like

Im currently having the exact same issue with my RS4D. Currently on V 0.19. Happy to attach logs if needed. I have also done all of the troubleshooting mentioned above by @Stormchaser

Edit: I was clued into this by receiving an email from Raspberry Shake saying we missed you we haven’t see your shake in three days. My shake is obviously “online” and producing data (locally.)

1 Like

Hello gscShake,

Glad to hear that your Shake is working again!

Yes, that is exactly the bug I was talking on. We are trying to focus our resources to find what is causing it so that, in v0.20, it will not be causing problems anymore.

The main issue is that not all Shakes are experiencing this, and the vast majority just reconnects (or connects) without issues, so finding the cause is key to solve all, as it can be imagined.

Regarding your follow up, no, if the Shake shows “Not connected” then the data is only stored locally, but is not uploaded to the server. There are backfilling protocols in place, however, that we are trying to improve so that issues like these will become non-issues in the future. It’s a long job, but surely worth it.

Hello SouthernCAEarthquake,

So, to be clear, you have tried this

Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Make sure that the Forward Data box is checked, and then click Save and Restart.

and it has not worked in reconnecting your Shake, is that right?

If so, could you please shut down the Shake, wait for around 5 minutes, then turn it on again, and try the same procedure?

If it doesn’t work again, can you wait for 30 min, download the logs and post them here? Thank you.

Hi Stormchaser,
Yes I have tried and verified that data forwarding is enabled, restarted and nothing changed.
However, simply shutting down for five minutes has solved the issue :slight_smile: (should of diffidently tried that first!)

Also, don’t think this is the right spot but if the whole blip issue can be fixed through software maybe that’s something that could be included/fixed in a future update?

Anyways, thank for the great support as always!

The shake shows that it’s connected to the server but I don’t see the shake on Station View. I’m Assuming the servers need time to maybe re-register the shake?

1 Like


Happy to hear that the Shake is connected and live streaming data again! Yes, it can take a bit of time, sometimes, to appear again on our services, but it is now visible on StationView: RS StationView

It’s no problem at all, I am here for this too! Thanks for the reminder, it is in our list of things to cover, and it will addressed in the future when resources allow.

1 Like