Shake working perfectly, Boom at the same place not connecting

Tried everything, power cycling, restarting - this is where the journey ends.

The logs would help.

I assume I’ll have to be on site for them, will try when I’ll be back there.

Thanks j

No, you can just click on the red “Download Log Files” button, and they will be downloaded onto the computer you are viewing the status from.

Hi, I never got there, with a screen stuck like above I don’t know the “name” of the station and so no way to get something on the computer remotely.

Hello Weatherdude, welcome to our community!

Yes, as Philip has suggested, the logs would definitely help in this situation. It appears that the Shake OS cannot recognize the name of the station, and thus it does not proceed forward with the setup and the connection to our servers.

With no hurry, when you can, please download the logs and then post them here on the forum, so that I can take a look at them. Also, since the installation is remote, please check that all the connection appear solidly in place, and that the blue Shake board is firmly installed on the Pi board below it. It’s better to do all verifications at once since you don’t have the Shake close to you.

Thank you.

Thanks, will do when back on site next week.

Best j

1 Like

Here is the log fileRSH…2022-04-25T12 06 11.logs.tar (219 KB)

Please let me know, thanks.

1 Like

There is nothing loose inside.

1 Like

I took a quick look at the logs. Things don’t look right:

 System Report:	Mon Apr 25 12:06:04 UTC 2022
       OS Version : Raspbian GNU/Linux 10 (buster)
   Kernel version : Linux raspberryshake 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l GNU/Linux
 Software Version : v0.20
 Firmware Version : unknown
      ODF Version : unknown
 Computer Info
 /usr/local/bin/myShake: line 247: /opt/settings/sys/PI-version.txt: No such file or directory
    RPi revision :  (unknown)
 /usr/local/bin/myShake: line 250: /opt/settings/sys/ODFSPNAME.txt: No such file or directory
 ODF Serial Port : 
     MAC Address : b8:27:eb:d6:59:e1
          UpTime : 12:06:04 up 4 min,  0 users,  load average: 0.02, 0.12, 0.07
     System time : Mon Apr 25 12:06:04 UTC 2022:
      Disc usage : /dev/root  7.4G  3.2G  4.1G  44% /
        CPU Temp : 40 C
 System Info
 heli_ewII : NOT Running
       OWS : NOT Running
  SeedLink : NOT Running
       ODF : NOT Running
 slarchive : NOT Running
 SL info:
 NONE Available
 crontab Info:
 @daily /usr/local/bin/myShake
 @hourly /usr/local/bin/clean-logs
 40 5 * * 2  /usr/local/bin/rsh-sw-fetcher C >/dev/null 2>&1
 Station Info
 Data-Sharing Mode : ON
  Data Server Conn : OFF
    Save Data Days : 7
        Heli Scale : 0.5
 cat: /opt/settings/sys/NET.txt: No such file or directory
 cat: /opt/settings/sys/STN.txt: No such file or directory
 cat: /opt/settings/sys/LOC.txt: No such file or directory
 cat: /opt/settings/sys/CHN.disp.txt: No such file or directory
      Station Name : ...
          Geophone : R-SHAKE

Looks like /opt/settings/sys might be completely empty… I don’t know how that hets provisioned, but it may be something to do with the services not running:

 heli_ewII : NOT Running
       OWS : NOT Running
  SeedLink : NOT Running
       ODF : NOT Running
 slarchive : NOT Running

@Stormchaser can probably tell you more about that. While waiting for him to come back online, if you have a spare SD card, it might be worth creating a new image and seeing if that fixes things.

1 Like

Hello again Weatherdude,

Thank you for the logs. Yes, as Philip also stated, there is definitely something that is not proceeding as it should with the Boom and the fact that nothing is loose inside is definitely good news.

The cause of the status that you are experiencing is caused by the fact that the Pi board cannot seem to reach the blue Shake board above it. This line shows the problem:

2022 115 12:03:15: Is the Pi computer connected to the Raspberry Shake Board? Please confirm and try again.

Since you have already checked that everything inside appears to be solidly connected, can you please try, if you haven’t already, to re-burn the microSD card? This solution has also provided way to possibly go around this issue, that could be caused by corrupted files on the card itself. The instructions on how to do so are in this post on our forum: Server Connection: Not connected Old Shake - #13 by Stormchaser

Thanks, will try this!


Hello all.

I recognise that reviving old topics is generally frowned upon, but I am writing about the same hardware item this thread was created for. After the topic being on the backburner for a long time, Weatherdude had sent the device to me to work out the problems in the hope that I might have more luck figuring out what was going on.

I was able to reflash the SD card, but the problem remained. Basically the problem is the same as described by weatherdude, with key part being the error message

2023 101 17:56:42: Unable to read Firmware version number off of Serial Port /dev/serial0 after trying for 15 seconds, cannot continue!
2023 101 17:56:42: Is the Pi computer connected to the Raspberry Shake Board?  Please confirm and try again.

The blue light on the Boom board does turn on(solid blue) when powering on the device, so it is receiving power. In addition, I did a GPIO test with the board removed, and I was able to verify that the GPIO ports seem to be working. Hence, it seems that something on the Boom board does not want to talk with the Pi.

Just reaching out in one last hope…

Hello es5nhc, welcome to our community!

Thank you for your additional checks and feedback about the status of this Shake unit. At this point, I think we have done all that we could in terms of remote assistance:

  1. microSD card has been re-burned
  2. all connections of the Shake have been examined after disassembling it
  3. your GPIO test appears to confirm that the Pi is working

I would recommend you contact sales [at] raspberryshake [dot] org so that they can organize what’s needed for you to send the unit back to us. We will then be able to examine it in our lab, trying to find what is not working with it, and what was the possible source of the issues you both have experienced.

As a last test before this, if you haven’t tried it yet, you could burn a different microSD card (if you have one available around) and see if the problem persists. If yes, then my previous advice remains.

Thank you, I will be busy in the coming days but will try a different SD card over the weekend just in case. If that fails, I’ll drop an e-mail.


Attempted again on a different SD card and got the same result. So looks like end of the road. What documentation do I need to include when sending the e-mail?

Hello es5nhc,

I’m sorry to hear that even a different microSD has not solved the issue. And yes, we have pursued all remote support avenues as of now.

No particular documentation is required, as we have a chronology of all the tests you and the previous user have made here on this topic. Our team will guide you via email to where to send the Shake and provide updates as soon as our lab has examined it.

If there is anything else that is needed, they will tell you what. Just reference this topic in your email to sales [at] raspberryshake [dot] org, and that will be enough.