Server Connection: Not Connected

Thanks for your help!

As a follow up, I brought the RS3D home from work to plug into my home network, and it’s working great! I’ve asked the IT specialist to open up those ports for the university network.

1 Like

Hello, I’m having similar issues connecting to the servers as dbeebe so I thought I’d post on here rather than starting a new topic, so hopefully this will get picked up!

I’m setting up a RS1D for the first time but it doesn’t seem to be connecting to the servers. I’ve attached my log file below. I’ll be interested to know if this is a unit issue or my internet (more likely) as I’ve had to bring home 13 shakes and a boom home from university as the network there was not welcoming to my shakes!

Thanks for you help in advance!


RSH.R520B.2020-08-08T09_42_32.logs.tar (421.5 KB)


from the logfile

2020 221 09:24:04>> NTP timing is not available, so an accurate data timestamp is also not possible.|
2020 221 09:24:04>> Data will be streamed locally only using HOST Computer's clock time!|
2020 221 09:24:04>> If Data-Sharing is desired, NTP *must* be available before this can happen!|

which explains why you are not getting connected to the server.

from the logfile postboot.log:

2020 221 09:23:49: Unable to resolve hostname '', most likely no DNS server available
2020 221 09:23:52: NTP failed to start, continuing without it
2020 221 09:23:52: There is still no internet connection after 132 seconds. Timing will not be accurate until NTP is available!
2020 221 09:23:52: System will check network status every 60 seconds.  When network connection is detected, services will automatically restart.

which explains why there is no NTP services, since the NTP daemon needs NTP servers to get its time from, which requires a DNS server to resolve the server names.

from the logfile myshake.out:

       Nameservers :

which looks a bit strange if you are on a home network. i will guess that this DNS server is not accessible from your home network, and so accessing NTP servers and Shake data servers will not be possible.

cheers, hope this helps,


Hi Richard,

Thanks for the quick response! Do you have any suggestions for how to resolve this or is this a dead end?


Hello adamcotterill,

Thank you for explaining the situation! There are two possible ways - setting a manual IP and DNS in the http://rs.local web config, or adding a line to /etc/dhcpcd.conf in the Shake filesystem.

  1. The first doesn’t require logging into the Shake. Navigate to rs.local, make note of the Shake’s IP address, then click on the Settings gear icon (high on the left) to access the configuration menu.

    Click on NETWORK, then under ETHERNET SETTINGS, click on “Enable static IP”.

    Fill out the Static IP field with the address you copied from the front page.

    Fill out the DNS server field with the server of your choice or a generic but reliable DNS service. OpenDNS, which is, is a good choice. You can also use Cloudflare DNS service by entering or Google by entering

The second way, a bit more complex, in which you can keep your Shake on a dynamic IP (assigned by your modem/router):

  1. SSH into the Shake (guide here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake)

    Once you’re in, copy and paste these commands (this example is for Cloudflare DNS):

    sudo echo 'static domain_name_servers=' >> /etc/dhcpcd.conf
    sudo service dhcpcd restart

    Now make sure those changes took hold:

    nano /etc/resolv.conf

    The file should look like the following:

    # Generated by resolvconf

You should not need to restart, these changes will take effect immediately, but if you want, you can still do it.

Hi Stormchaser,

Sorry for the slow reply, I sadly didn’t have time to play with the shake yesterday!

I initially tried the ssh method and I couldn’t get this to work. I actually wasn’t able to paste the commands into the terminal once I was connected to the shakes via ssh so I manually typed the commands (I think correctly!). Maybe as I wasn’t able to paste I was doing something wrong? When I ran that final command I didn’t get the same file output as you.

So I tried the static IP method instead. This isn’t working either. When I define the IP and DNS, I click save and reboot. Once the shake is done rebooting, I still have no network connection after 5-10 mins. When I go back to the Network settings page, the tick box is unticked, the IP is undefined and the DNS is even when I’ve set other DNS servers. I tried both method a few times!

Thanks for your help!

Hello adamcotterill,

I understand the new issue with the static IP method. We have seen that sometimes pops up, but it is very random, so we haven’t been able to pinpoint the exact cause.

Could you please post a screenshot of the current content of the resolv.conf file that you tried to edit?

And, can you try to edit it again via SSH? The usual Ctrl+C and Ctrl+V combination does not work in the command line window, and you need to right-click on the window itself and then select paste from the menu to actually paste the commands I listed.

See if in this way you are able to manually edit that file, if you haven’t already tried such a method.

Okay - that copy and paste info was very helpful! The commands seem to have worked this time although the output is slightly different from what you suggested but I think it looks positive. Sadly though my shake has not connected to the server still. I’ve left it for 15/20 mins to see. I will keep checking in on it throughout the day just in case.


Yes, the commands have been executed as they were supposed to, but there has been a bit of a mix up with all those nameservers, for reasons that as of now I could not list.

Could you please post a screenshot of the dhcpcd.conf file too? You will find it in the same folder of the previous one.

Hopefully this is the right thing?

Hi Stormchaser I’d like to just add another data log from a second RS1D I have just set up which has connected to the servers straight away. I wonder if this will be able to help you pinpoint the issue with the first one. Thanks!

RSH.R6454.2021-03-28T17_37_28.logs.tar (52.5 KB)

Hello adam,

thank you for the new logs. It’s easy to see that this one is working perfectly as it should, and the fact that is connected to the same network as the other make the errors we were seeing a bit baffling.

Could you please post the screenshots of the dhcpcd.conf and resolv.conf files of this second working Shake? Thank you.

Okay here are the screenshots from the working shake which to be clear I haven’t set a static IP on. The resolv.conf worked fine but the dhcpcd.conf looks like there was nothing in it? Is there a way to factory reset the non working shake? I just wonder if something got jumbled when I was trying to connect it to my university network?

Additional info is I’ve set up a further 4 shakes (RS4Ds this time) and they were fine too.


Hello Adam,

perfect, that’s what I wanted to see (and thank you for the confirmation that the other Shakes are working nominally).

As you have surely understood, this is what normal files look like, and there is an evident issue with the configuration of the first Shake. We can try a last thing before resetting everything:

please open the dhcpcd.conf file with

sudo nano /etc/dhcpcd.conf

and delete all the lines that start with static, thus leaving only interface eth0. Do not modify anything else.

Then do:

sudo service dhcpcd restart

to make sure those changes took hold and then check the output file with

nano /etc/resolv.conf

The file should look like the one from your working Shake.

If it doesn’t, then a reset is the best option left on the table. I can advise to:

  1. re-burn the ShakeOS on your current microSD card
  2. or get a new microSD (to erase the chance that this one got ruined) and burn the Shake OS there.

I know that this means to retrieve the Shake from its remote location, or going there personally, but there is no other way of correcting this via remote actions.

In both mentioned cases, these are the instructions to prepare the new OS image:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

I am able to the delete the lines, but in order to save the changes I need to select one of the options at the bottom and I’m not sure which one to use. Please could you advise? Thanks!

Hello adam,

for that, you just have to press enter to save the modifications you made, and then follow the instructions in my previous post.

Hi Stormchaser,

So I did update the dhcpcd.conf with your help saving the changes but when I checked the file it didn’t show the same as my working RS1D. So I left it over night as I was a bit reluctant to burn the SD card. I’ve just checked in this morning and it’s now connected to the server and the feed is appearing in shakenet! I’ve attached the log files from this morning. Would you mind looking at these and confirming that everything is working as it should be?


RSH.R520B.2021-03-31T10_07_08.logs.tar (1.4 MB)


Hello adam,

Great news! Yes, the Shake is working as expected now, and it is also streaming live data to our servers.