Raspberryshake get ip, connect to internet but can not be accessed through webinterface

Thank you CorofinShake,

Honestly, this is truly baffling. For some reason your local network modem/router is properly assigning IP and DNS addresses to the Shake, and the fact that you can access it locally is proof of this.

However, from the logs,

2021 103 00:42:55: Network detection failed, unable to curl or ping common sites
2021 103 00:42:55: No internet connection found
2021 103 00:42:55: Network detection failed, unable to curl or ping common sites

it appears that your Shake cannot get out to the wider internet, as proved also by the ping test that I had you do yesterday.

There are two things you can try now. Please shut down your Shake again first, then your modem/router. Wait for a couple of minutes, then restart your modem/router, and when it’s back online, please check again from your pc/laptop if the following ports are open (do not start the Shake now):

port 55555 [TCP]
port 55556 [TCP]
port 123 for TCP and UDP traffic in both directions

If they are still not open, please consult your modem/router manual on how to open them (port 123 in particular, since it is the one that regulates the time synchronisation). After they have been opened, start yuour Shake and wait for a bit (around one hour tops) to see if it manages to connect to our servers.

If the connection still doesn’t work, then you can try to change the DNS on the Shake, as explained in this page on our manual, Firewall issues? — Instructions on Setting Up Your Raspberry Shake , to see if this solves the issue. I’ll add some more info below.

There are two possible ways: setting a manual IP and DNS in the http://rs.local web config, or adding a line to /etc/dhcpcd.conf in the Shake filesystem.

  1. The first doesn’t require logging into the Shake. Navigate to rs.local, make note of the Shake’s IP address, then click on the Settings gear icon (high on the left) to access the configuration menu.Click on NETWORK, then under ETHERNET SETTINGS, click on “Enable static IP”.Fill out the Static IP field with the address you copied from the front page.Fill out the DNS server field with a more reliable DNS service. OpenDNS, which is 208.67.222.222, is a good choice. You can also use Cloudflare DNS service by entering 1.1.1.1 or Google by entering 8.8.8.8.

The second way, a bit more complex, in which you can keep your Shake on a dynamic IP (assigned by your modem/router):

  1. SSH into the Shake and, once you’re in, copy and paste these commands (this example is for Cloudflare DNS but, as stated, you can use others too):
sudo echo 'static domain_name_servers=1.1.1.1 1.0.0.1' >> /etc/dhcpcd.conf

Now make sure those changes took hold:

sudo service dhcpcd restart

And see if they took hold. The file should look like the following:

# Generated by resolvconf
nameserver 1.1.1.1
nameserver 1.0.0.1

You should not need to restart, these changes will take effect immediately, but if you want, you can still do it. If there is no connectivity change after a while, then you can retry with a different DNS server.

Hi StormChaser

What a saga!!

I worked my way through all your suggestions, but the network connections (either the internet or local network, but never both) continued to fail after 2 to 4 days. I also asked a computer network specialist to check, and he could not find any issues!

Finally, my early training of 50 years ago kicked in, and I got my volt meter out and checked the power supply.

The Shake is mounted in a ventilated metal case, bolted to the building’s concrete slab in the crawl space under the stairs. The Shake is electrically isolated from the case. The local environment is electrically noisy, with the house’s main switchboard, a UPS, wireless routers etc.

With a quality meter, I was able to measure varying voltages between the zero volt line on the Shake and the metal case of up to 43 volts ac, with a positive dc voltage at times of up to 20 volts.

A simple earth connection between the Shake and the metal case seems to have resolved the problem.

My Shake has been running successfully for over 22 days.

Thanks

CorofinShake

2 Likes

Hello CorofinShake,

what a saga indeed! I had seen your Shake online and I thought that the issue had been solved, but definitely not such a situation!

You know? This reminds me of when I built my first pc at home when I was 8. It continued to reset and restart every now and then and we could not find the cause, because everything seemed to be working fine!

Until… my father thought of grounding the external case of the pc. And bam! Everything was perfect after that!

Thank you for detailing the steps that you have taken, and explaining your process. It could be useful for other users too.

Enjoy your Shake!