Can't connect to server


my Raspberry shake won’t connect to server.

I plugged it to the network yersterday and it worked fine, but today I’m stuck with “Connexion au serveur : Non connecté” (I’m french).

I can open the config page with rs.local/ and go in all submenus and reboot the RS (I tried to reboot it many times of course).

I’ve managed to ssh my shake, and to ping google ( from the shake (in my console).

BUT I could’nt ping (10 packets transmitted, 0 received)

I’ve uploaded the log file.

RSH.R0DFB.2021-09-20T17_47_39.logs.tar (1.5 MB)

Thanks for your help !


in the log file, there is indeed an error indicating that on day 263, the data being read off the serial port is gibberish. you should verify the connections between the Pi and the Shake board and confirm everything is properly connected.

v0.19 has just gone out, as well, reboot your unit to pick up this update, perhaps (though unlikely) this could have a positive effect.


Thanks for your reply, but I’ve rebooted RS many times (even by doing “sudo reboot” via ssh, or by powering it off and on again).

I’ve finally managed to get version 0.19.

The connexion between the shake module and the Raspberry looks fine. And anyway, why can’t I connect to the server ?

Here is a fresh new log file :
RSH.R0DFB.2021-09-22T05_16_57.logs.tar (1.4 MB)

Hello pcosentino,

thank you for the new logs. As @ivor has suggested, when in the log files something like this appears:

2021 265 05:16:57>>	'AAPJU
2021 265 05:16:57>>	x???U?Z]?ÄL]ª
2021 265 05:16:57>>	AQºEBa?aà??ÔEñ?UÂEIÀ?ËÔEÑFªQ?%?c(
2021 265 05:16:57>>	U?'IðDY??e]?EEU
2021 265 05:16:57>>	áÄ?U?YIÐÉ?ÔUÁE
2021 265 05:16:57>>	c?RSeHYðYg??U?
2021 265 05:16:57>>	g?T	g?AY
2021 265 05:16:57>>	?'IÐ?ªÔUe?Q
2021 265 05:16:57>>	?TUBSÑFIàc??UM?EáªWñIIÀÈc?AQ??E1HE
2021 265 05:16:57>>	?D?BS%?W;
2021 265 05:16:57>>	u?$IÐÆQ?QYÛ
2021 265 05:16:57>>	SURUÂIYàU??QÑ?EQE?EEE
2021 265 05:16:57>>	5gUBWâIIÐ?Y?AQ???Ok3I]º?S?%?Î?Aúÿ_k?M?DY27S??Ë?AÐE
2021 265 05:16:57>>	'QAPJU
2021 265 05:16:57>>	x???U?Z]?ÄL]ª

it is caused by something that is not working as it should between the blue Shake board and the Pi board underneath. This is also supported by this other line in the logs:

2021 265 05:15:30: Unable to read Firmware version number off of Serial Port /dev/serial0 after trying for 15 seconds, cannot continue!
2021 265 05:15:30: Is the Pi computer connected to the Raspberry Shake Board?  Please confirm and try again.

which confirms the connection issue.

It is quite a strange situation because the Shake managed to connect successfully to our servers before all of this happened. To summarize, the Shake is able to reach our servers, but since the data flowing from the sensors is corrupted, no connection is established, and no data is uploaded.

Here are the solutions that I can suggest:

  1. Substitute the current Pi board with another one that you have around to see if that element was the cause of the issue.
  2. You could try to re-burn the microSD card (instructions here: Rest Raspberry Shake - #2 by Stormchaser), but I don’t think that the problem is located there.
  3. You can send back the Shake to us, and we will look at it in person and then send it back to you in nominal working conditions. If you choose to do this, please send an email to and they will guide you through the process.

Thank you.

I’ve returned my RS to an expert collegue who is trying to swap the Pi board.