WiFi Configuration Hangs

Hi there.

When I try to configure wifi access, the web interface just hangs at “Confirming your WiFi credentials”. I know that wifi is not recommended, but I will be using my Shake out in the field, where plugging into an ethernet network will not be possible - I’m planning to have it join a network that I’ll establish on another Raspberry Pi for communication and administration.

After doing this, it has stopped responding on the rs.local domain name. The only way I have been able to access it is via the IP address directly. When I open another browser tab and look back at the wireless settings, I can see that Connect to WiFi is checked, but none of my other settings have been persisted.

Any tips for getting the wifi configured properly? Thanks.

After referencing https://manual.raspberryshake.org/wifi.html?highlight=wifi, I was able to get the wifi configured by setting it up via the command line, manually disconnecting the ethernet cable, and rebooting it, but it still doesn’t seem to respond on rs.local.


the latest update to the software provides access to WiFi configuration from the front-end configuration interface. have you tried configuring it that way?

find the IP address of your unit (using the fing app, for example) and access the web interface from a browser directly:
https://192.168.x.x - or whatever

and then proceed to SETTINGS::NETWORK::WIFI SETTINGS, and select ‘Connect to WiFi’.

and let us know how this goes.


Hi Richard.

Thanks for the response. This is what I initially tried - the web interface just hung at “Confirming your WiFi credentials”. Please see the first post in this thread for more info.

My WiFi is working now, after configuring it from the command line, but I am still not able to connect to the Shake on rs.local - I need to connect directly via the IP address. Any tips on troubleshooting that?

hi ireasor,

(apologies for misreading your original post…)

first, i am curious to know what commands you needed to execute to get this to work, this is supposed to work 100% from the interface.

re: rs.local - are you accessing the shake using rs.local from a computer on the same subnet, i.e., a computer that is also connected to the same wifi network? and / or is the shake also connected via ethernet at the same time?

confirm both:

  1. both computers are on the same subnet
  2. ethernet on Shake Pi is disconnected

and what OS and browser are you trying to access from?



Hi Richard,

I configured wifi from the command line using the advanced steps at https://manual.raspberryshake.org/wifi.html. I had to unplug the ethernet and manually restart the Raspberry Shake afterwards to get it to connect to the wifi network.

Both computers (my laptop and the Rasberry Shake) are connected through the same router. At first, the Shake was connected via ethernet while my laptop was connected to the wifi. I can confirm that while connected to the same WiFi network that the Shake doesn’t respond via rs.local, though. Both computers are on the 192.168.1 subnet and I can ssh to the Shake from my laptop using its IP address (retrieved from the router).

Hi, I had the same problem, the web interface locked up on a new install reporting "Confirming your WiFi credentials”. In the end I had to pull the plug on the new setup and this corrupted the SD card. With a new install image the same thing happened again, it locks up. This is on a Pi Zero with USB to Ethernet dongle. On the third attempt I used SSH and hand configured the WiFI as suggested above and that worked fine. This did then create a new station though as the MAC adress is different.

Thanks for posting the solution, it worked for me.

Is there a way to delete the rogue station as now I appear to have a working station ID plus a rogue dead one?

Thanks for reporting @ireasor @Aridlands. We are looking into this.