Weird issue with RS4D

Hi Everyone,

I just had a weird issue with my 4D withing the last 1 hour

21:31 - weird spike that set off the alarm in SWARM (not a quake)
21:39 - measurements went flat “0” in SWARM
21:42 - another spike that set off the alarm in SWARM (not a quake)
21:43 - measurements went flat “0” in SWARM
21:45 - Rsudp alarm was set off
21:45 - measurements went flat “0” in SWARM
21:46 - measurements went flat “0” in SWARM

I tried accessing RS4D via web (using IP) and no response
I tried SSH and no response
I could ping the RS4D

21:49 - I power cycled the 4D
21:50 - Got access to the web interface and downloaded log files
21:52 - downloaded another set of log files once everything came up
21:52 - everything is back to normal
22:15 - Picked up an earthquake around 224 km :slight_smile:

Station is R7078

ThanksRSH.R7078.2020-02-23T21_52_35.logs.tar (6.4 MB) RSH.R7078.2020-02-23T21_50_44.logs.tar (6.4 MB)

One problem could be that your Shake has an unreliable internet connection. NTP adjusts the time on your Shake multiple times, including adjustments of more than 17 seconds. Also, your Shake was disconnected from the server from 2020-02-23 10:55 UTC to 2020-02-23 21:50 UTC.

Try setting the DNS server to and see if that helps.

There are also problems with the Shake throwing away some data packets at the times you describe, which may be due to the CPU being occupied when it should be reading data off the port, or it may be due to a bad connection between the Shake board and the Pi.

The first case could be made slightly less likely by giving the Shake a reliable DNS server as suggested above. The second case may be that the Shake board is not seated entirely correctly on the Pi GPIO header, in which case adjusting the seating/cleaning the contacts could help.

1 Like