Server connection unable to connect

We just purchased new Raspberry shake 3D and RS&BOOM. The RS&BOOM is working perfectly but the 3D is unable to connect to the sever, probably due to DNS error. The log file is attached this post. Thank youCapture

Thank you. RSH.R6340.2020-08-08T13_04_29.logs.tar (789 KB)

Hello faladeayomiposi, welcome to the community!

I moved your issue to a new topic, so that we can stay concentrated to solve it.

Thank you for the logs. From them, it appears that this Shake has not been assigned (or cannot find) a good DNS, as the following lines show:

2020 221 12:35:33: Unable to resolve hostname '', most likely no DNS server available
2020 221 12:35:33: No internet connection found
2020 221 12:35:43: Unable to resolve hostname '', most likely no DNS server available

Also, in your logs the DNS is listed as: Nameservers : Is it the same one of the working Shake?

Could you please post the logs from this second (working) Shake too, so that I can make a comparison between the two, and try to understand where the problem is?

Thank you.

No. I have changed the DNS several times but it does not connect with the server, while RS&BOOM connects with DNS The assigned IP is RSH.R4285.2021-05-03T20_00_07.logs.tar (854 KB)
The RS&Boom log has been attached to this post. I noticed today that the RS&BOOM was connected but the connection did not reflect on Shakenet server


Perfect, thank you for the new logs. What you have highlighted is exactly the problem. For some reason, your local network is not assigning the proper IP and DNS addresses to the not-connecting Shake, while it has done it correctly for the second one.

Actually, I can see that even this connecting one, at the start, had the same problem, but then it was promptly resolved by your modem/router.

These are our manual procedures to assign IP and DNS addresses to our Shakes. If you have already tried one of them, you can try with the second one. They are explained in this page on our manual, Firewall issues? — Instructions on Setting Up Your Raspberry Shake , but I’ll add some more info below.

There are two possible ways: setting a manual IP and DNS in the http://rs.local web config, or adding a line to /etc/dhcpcd.conf in the Shake filesystem.

  1. The first doesn’t require logging into the Shake. Navigate to rs.local, make note of the Shake’s IP address, then click on the Settings gear icon (high on the left) to access the configuration menu.Click on NETWORK, then under ETHERNET SETTINGS, click on “Enable static IP”.Fill out the Static IP field with the address you copied from the front page. Fill out the DNS server field with a more reliable DNS service. OpenDNS, which is, is a good choice. You can also use Cloudflare DNS service by entering or Google by entering

The second way, a bit more complex, in which you can keep your Shake on a dynamic IP (assigned by your modem/router):

  1. SSH into the Shake (guide here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake )Once you’re in, copy and paste these commands (this example is for Cloudflare DNS):
sudo echo 'static domain_name_servers=' >> /etc/dhcpcd.conf

Now make sure those changes took hold:

sudo service dhcpcd restart

And see if they are properly displayed in the file with this command:

nano /etc/resolv.conf

The file should look like the following:

# Generated by resolvconf

You should not need to restart, these changes will take effect immediately, but if you want, you can still do it.

Thank you for your prompt response. I have tried the two methods but none worked. The first method, I checked the static IP and typed the IP and DNS but it did not resolve it. I noticed that whenever I save and ask it to reboot, the static IP will uncheck itself, while the DNS will automatically change to default. When using ssh to change the IP, the IP sometimes changes without connecting and after a while it will go back to default which is After following the second procedure, which did not work,

the image attached shows the final display.


Firstly, thank you for reporting this issue with the “Save and Reboot” in the DNS section. I have opened a ticket for our software team, and they will address it in the coming weeks.

Onto the second method, could you please post a screenshot of the /etc/dhcpcd.conf file? So that I can try to understand what may be causing this issue.

Thank you.

Thank you. Concerning the connection issue, it has not connected yet. Kindly find attached the copied file of /etc/dhcpcd.conf dhcpcd.conf (2.7 KB) . You can open it with notepad or vi. Thank you

Thank you for the entire file, it was what I needed.

As you can see, there are too many lines starting with static... and they likely are the cause of why the Shake does not manage to connect to the network.

Thus, please remove all the lines that start with static... (in my notepad they go from line 2 to line 49), leaving only interface eth0 as the first line and all the comes below line 50 untouched.

Then do:

sudo service dhcpcd restart

and then wait for a while (some users have said that it can take up to 3 hours) to see if the Shake manages to connect successfully to the network, and it is assigned a correct IP and DNS by your modem/router. You can also reboot the Shake, if you want.

If everything works, perfect! If not, I would like to see again the /etc/dhcpcd.conf and /etc/resolv.conf files, if you can attach them again.

Thank you.

Bravo! It has connected. Thanks a lot

1 Like

Happy to hear that! You’re welcome, no problem at all.

Enjoy your Shake!