Server Connection; Not Connected

I setup my RSBoom in my office at UC San Diego. It fails to connect to the server. I am suspecting this might be a firewall issue, but I am not sure which port it uses.

A couple of strange things, I turned on Data Forwarding, and rebooted the unit. However, at no point did it ask for a Username or Password. Did a full reboot, and still didn’t asked for login credentials.

I have tried to pull the log files both from my iPad, and from my MacBook Pro. However, every time I click on the Log Files button, it launches a page, which never completes. I never actually get to the log file, since the unit appears to hang. The only way I can recover communication is to cycle power to the device.

I am thinking the log files might shed some light on my problems, but if I can’t access them, then I am not sure how to proceed.

Note that I left the unit up for several days, and the Data Producer and Data Consumer finally turned on. However, the server connection has never worked.

I would appreciate any help in sorting out these problem(s).

Hello Chris, welcome to the community!

Yes, the logs would be very useful in trying to see what it is happening. It’s the first time that we hear about this issue of the process to retrieve them hanging as you describe, so thank you for reporting it to us.

I think that it is some kind of firewall problem too, probably some ports not opened as they should, or some IP-blocking protocol.

What you can check is that, in your network (modem/router/IT administrator), the following ports are open:

port 55555 [TCP]
port 55556 [TCP]
port 123 for TCP and UDP traffic in both directions

and that the IP address assigned to your Shake (which I can read being is not blocked from having connection with the external networks.

Let’s see what results these checks will produce, and then we’ll move forward to the logs problem.

Hi Stormchaser,

Thank you for getting back to me. I reached out to my Physics Department IT Group, and they had to register the MAC Address for the RS&BOOM with out system. I am normally WFH, but I went into my office yesterday and it appeared to be working fine.

Also I was able to download the logs to my iPad. In the last week I updated my iPad from iPadOS 14.5 to 14.5.1. Don’t know if that made a difference, or if getting the network connection resolved was the problem. Either way I am up and running. I did notice that my location on the Shake and Boom Maps are slightly different, and also different from the location in my profile. They aren’t greatly off, but I found this to be curious.,

Thanks again for giving me the port information that I needed to make the thing work. That was very helpful in resolving the problem.

Best Regards,

Chris Munson


Hello Chris,

Really happy to hear that, and that your RSBOOM is working as expected!

Regarding your geographical position question, we have the answer here in our manual: Commonly Asked Questions — Instructions on Setting Up Your Raspberry Shake

Enjoy your Shake!

Hi Stormchase,

Thanks for the link to the location explanation. I figured there was some dithering going on. Now to setup my RS4D. Thanks again for your help in getting me up and running.


You’re welcome, it was no problem at all. Happy to hear of your second Shake!

We will be eagerly waiting for its first data on our network!