Server Connection is stuck at Not Connected

My Raspberry Shake & Boom(AM.RB6FC.00.[EHZ][HDF]) had it’s SD card go bad so I replaced it but it’s Server Connection is stuck at Not Connected. How do I get it to connect? My other device on the same network is connected.

Hello Forever, welcome to the community!

It is a bit difficult to discern what could be the cause of the connectino issue without the logs. Can you please post them?

In case you don’t remember how to do it, they are downloadable from the Raspberry Shake’s web configuration page, accessible entering the rs.local address in your browser, then by clicking on the “Download Logs” button.

Thanks for the replay, I have attached the requested file.

RSH.RB6FC.2020-10-31T20_04_13.logs.tar (1.2 MB)

No problem at all, thank you for the logs.

From them, it is possible to see that while the WiFi module is turned ON, no network can be found to reach the NTP servers (the ones that take care of the time synchronization) and our data servers to upload your recordings. These lines explain the issue:

2020 302 20:03:26: Network detection failed, unable to curl or ping common sites
2020 302 20:03:26: No internet connection found
2020 302 20:03:26: Network detection failed, unable to curl or ping common sites

The first thing you can try (if you haven’t already) is simply to shut down your Shake from the rs.local web interface, then your modem/router, wait a couple of minutes, and then turn on again the modem first and the Shake second, to see if it was a simple issue with the modem/router itself.

If this has not solved the issue, then please shut down your Shake again first, then your modem/router. Wait for a couple of minutes, then restart your modem/router, and when it’s back online, please check from your pc/laptop if the following ports are open (do not start the Shake now):

port 55555 [TCP]
port 55556 [TCP]
port 123 for TCP and UDP traffic in both directions

After checking this, and opening the ports, if needed, please start your Shake, wait for around 10 minutes and then let’s check that your unit can reach our servers. Can you try to SSH into the Shake by entering this command in a prompt (with admin authorization)?

ssh myshake@rs.local

Naturally, if during the configuration you have changed the password, you should input that one, and not the provided default (which is shakeme).

Once you are in, can you try and ping the following addresses?

  • ping -c 10
  • ping -c 10

The first one is the Google server, while the second is our data server. The two commands will execute the exchange ten times, and your expected result is a 0% packet loss for both instances.

I’ll wait for you to try this before going forward.

I tried the restarts with no luck.
The ports are good.
When logged into the shake I’m not able to ping the addresses.
I tried my other shake and was able to pink the addresses.

So it would seem my network is fine but something with the newly setup shake is wrong.

I see, thank you for the tests. Have you assembled this Shake yourself? And, is the other Shake (the working one) connected via WiFi too?

It seems that the WiFi module of this one does not manage to recognize any network. Can you please see if it will work with a LAN cable if you have one available?

Just disable the WiFi module temporarily from the rs.local - Settings - Network - WiFi Settings, connect the Shake to your modem/router with the cable and try again to ping those addresses. If this works (or not), then can you please disconnect the LAN cable, re-enable the WiFi module, and try pinging again?

In this way, we will be able to see if there is a hardware problem somewhere.

Yes I assembled the shake myself. The other one is not using WiFi.

I attached the shake to a LAN cable and disabled the WiFi.
I still can’t ping the address with the LAN connection.
I tried the WiFi again and it also can not ping the addresses.

After a full wipe and reinstall of the OS along with many failed attempts to turn the WiFi on it’s now working. It kept hanging up authenticating the WiFi and needed to be rebooted.

1 Like

Glad to hear that!

It was actually what I would have suggested you as next step. Do a full wipe and reinstall the Shake OS to see if that would have changed something.

If not, then the Raspberry Pi would have been the problem, but it’s good that now everything works.

Enjoy Shaking!