RSUDP not receiving data


I’ve been running RSUDP previously with great success, but now am unable to receive data and I can’t figure out why. The change that has happened is that I put a new hard drive in my PC and installed rsudp v1.0.1. I also had to register my computer with ZeroTier.

I can access and download files from thr shake, but am let with “Waiting for UDP data on port 21981…”

Here are some screen shots, I have changed the port and added the ip address into


Here is my log file.

RSH.RDCD8.2021-02-26T05_03_41.logs.tar (3.2 MB)

Hello Alan,

Thank you for the logs. From them, nothing appears out of place, and the Shake seems to be performing nominally.

Did you have this ZeroTier software before too, or it has been activated when you replaced the hard drive? If this is the case, I think that it is the main reason why RSUDP cannot communicate with the Shake, even if the port has been set up there.

You can try the following, to see if these operations solve the issue, but otherwise, I would recommend checking the manual of that software to clear up any doubts.

  1. Have you tried to SSH into the Shake (guide here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake) and try to ping your computer from there? Do/Did you get a positive response from that?
  2. On the same page, have you tried to ping the Shake from your pc?
  3. You can also try to delete the UDP element from the list on the Shake, reboot it, wait for ~5 minutes, and redo the UDP datacast from scratch.
  4. Can you also try to run RSUDP without the ZeroTier software active, or it is a requirement for your pc to operate that you cannot bypass?

Hi Stormchaser,

Thanks for your reply. I was able to SSH into the shake and ping my computer, and also ping the shake from my computer. Both were done via the ZeroTier connection.

I deleted the UDP element from the Datacast section of the web interface, then restarted, waited quite a while and set up the values again. This didn’t change the situation though.

I’m able to download the data files from the onboard FTP, but having to do this isn’t optimal.

ZeroTier is required because the shake is in one city and I am in another. It is also set up for field logging for microseismic studies, so ideally needs to be able to stream from the field. It is software that is suggested on the Raspberry Shake website.

I’m investigating if there is a firewall issue somewhere and if there is something in ZeroTier that is not configured correctly, but the network has not changed, I just reconnected with my updated PC.

Is there a way to monitor UDP transmission on the shake side? This would help show if data was being sent.


Ok so I found the onboard script and hot heaps of data when I ran it so looks like the shake is producing data.

Hello AlanT,

thank you for your report. Yes, I can imagine that having to do that via FTP can be bothersome.

You have already found it, but yes, that script is the one that will show if there is any UDP tx activity, and as you can see, it is working.

I think that there is some kind of port setup on the ZeroTier software or also a firewall that needs to be done before the PC with RSUDP can correctly receive the data from the Shake.

Have you made some other tests during these days?

Hi Stormchaser,

I set my laptop up to do the job. It didn’t work initially, but when I paused the firewall I got a connection immediately. Both have the same internet security system, Eset, so I’m thinking that this will be the same for my desktop, but I’ve not managed to get it working on there yet.

I’ll report back if I discover a more in depth answer.

Thanks for your help.


This is a “just in case” suggestion. Don’t suppose the IP address of your computer changed?