RS1D problem

I am forwarding my RS1D to my friend. Station AM.R4f07 is connected, but there is some problems with forwarding data to server.
Here i send the logs…RSH.R4F07.2021-12-15T19 19 04.logs.tar (2.9 MB)

Hello Marco,

Thank you for contacting us about this problem with your friend’s RS1D.

I can see, from the uploaded data, that there are a lot of gaps in the stream, like in the image you posted. Initially, I thought that there were connection problems, but, by the looks of it, the Shake can see and communicate with NTP and with our servers fine.

I noticed that he has both LAN and WiFi enabled, here on one of the logs:

Ethernet is ON and WiFi interface is enabled.

We usually recommend to not have both of the interfaces ON, so maybe he can disable the WiFi if he is using a LAN cable, or disconnect the LAN cable if he is using the WiFi. This helps in connectivity performance.

Antoher thing that I noticed is that there are corrupted data packets that are, more likely, the cause of the interruptions in the stream. Do you know (or can you ask) if he assembled the Shake with a DIY kit, or if he got it as a whole turnkey model?

Also, can you ask him to shut down the Shake, wait for half an hour, turn it on again, then wait until this evening, and download/send the logs again? I want to check if the corrupted packets appear again or not.

We are disable WIFI conection, we are shut down raspberry for 30 minutes, but the problem is not solved.
Hee LOgs after doing everything…

RSH.R4F07.2021-12-16T14 22 15.logs.tar (5.5 MB)

By the way friend has fixed IP connection fo web. We are connecting RPI via switch, but after that we try also to connect directly without switch but probem is still there.

This RS1d was buyed from your storage…

hello marco,

looking at the error logfile, the problem here is definitely related to the data coming off the serial port, it is corrupted and unable to be processed. when this is detected, the data is thrown away, the error is reported, and the program tries again.

please check the physical connections between the following components:

  1. the geophone and shake board
  2. the shake board and the raspberry pi

it is likely that something is loose, or corroded, or any number of physical-based possibilities that can compromise the data transfer between the components.

cheers, hope this helps,

Hi Ivor, that should be the problem. I send email to my fried and he will check all the connections betwen the geophone and the board and the pi.
I will let you know soon.

1 Like

So today we opened the RS1D and cleaned all the connections. Here I send the logs afer rebooting the RS1D. But the probem is not solved. Just reminder. The friend has fixed IP at home, maybe is there the problem I dont know… Marco

RSH.R4F07.2021-12-21T18_30_19.logs.tar (5.4 MB)

2day i will flash new SD card, and see what happened…

Hello Marco,

Thank you for the logs from your friend. I can see that the Shake seems to boot up properly, and also see our servers, so the necessary ports seem to be open and usable.

I would suggest the same solution that you are doing now, since it will allow us to start with a clean system and see if there were hidden issues that were causing that problem. Possibly, the fixed IP was the cause, but let’s see what happens.

Did your friend need the fixed IP as a requirement of his local network, or the Shake can be left with the IP that the modem/router will automatically assign? In this case, let’s try to see if not setting a fixed IP will solve the problem, and we will proceed from there.

Hi guys…
I am glad to announce that RS1D now working good. It was problem in SD card. Anyway thanks for the help.
I wish to you and your family merry christmas and happy new year 2022.



That is great to know Marco! Happy to hear that!

Happy holidays and new year to you and your friend too!