Rs.local empty of infomrtion but pi is working

Hello Raspberry Shake,

I am having trouble setting up my shakes. They are new DIY kits with Shake board v8 and RPi 4 B. I have tried changing out the SD cards, and checking the connection of the shake board with three different units and none of them will show any information on rs.local but the Pis are working and I can SSH into them. The blue light on the shake board lights up and the connection to the Pi looks good on all three. I am attaching the log files for one of the shakes. I am hoping to get this sorted out as there are still 8 more I have to get working :slightly_smiling_face:

Thanks for your help!

Dr. Ward

RSH…2021-09-16T23 36 53.logs.tar (2.1 MB)

Hello Dr. Ward, welcome to our community!

Thank you for reporting this issue. We are aware of this problem, and have worked in the last weeks to solve it. It is caused due to the fact that the Raspberry Pi board that you are using is a recent model issue, and thus the Shake OS does not recognize it.

However, the solution is finally ready, and it will be implemented later today or tomorrow, with the launch of the Shake OS v0.19, which will fix the problem. Just keep your Shake connected to the network (or reboot it, if you want to update faster) and our software will do the rest.

In case there are further issues after the update, feel free to contact us again.


please reboot your unit to download version 0.19. the update will be automatically be downloaded and applied when it is connected to the internet.


1 Like

Thanks everyone.

That seemed to fix the initial problem but now, the shake will not connect to the server. I can ssh into the shake and it is recording data, just not forwarding data now. I can see the shake on shake net as well but no data is streaming there either. Any easy fixes?


RSH.R5E2A.2021-09-22T18 11 20.logs.tar (408.5 KB)


glad to see that data is flowing now!

looking at the logs, i suspect there is a mismatch between the home page saying that data-forwarding is turned ON vs. if it actually is.

please try to reset the data forwarding through the front-end:

  1. navigate to Settings::Data
  2. confirm ‘Forward Data’ checkbox is checked
  3. click on ‘Save and Restart’ button at bottom


1 Like

I concur with @ivor.

From your logs (thank you for posting them) this line shows that the data forwarding has not been activated (even if the webpage seems to suggest the opposite):

Data-Sharing Mode : OFF

Please execute the procedure listed in the post above this, and everything should be fine.

If not, we are here to help!

Thanks again for the quick feedback.

It sort of worked. If I go and un-select ‘data forwarding’ using the rs.local portal and then re-select it and click save and restart, it starts to work.

If however, I then reboot the shake using the same rs.local portal, it seems to revert to showing data forward being selected but then not forwarding data. This problem can then again be corrected by repeating the above steps on rs.local.

I wonder if there is some default of not data forwarding it reverts to on a reboot? This is only a concern as I will be placing the shakes with people who may not have the ability to select the data forwarding box using the rs.local portal if say, the power goes out and restarts the shake. I also, wonder, is there a command line way of turning on the data forwarding option?

Or maybe I am way off on my diagnosis? Attached are the log files after a reboot with the data forwarding working correctly but reverting to not forwarding after the reboot.

Dr. Ward

RSH.R5E2A.2021-09-22T20 25 51.logs.tar (488 KB)


that is strange, we’ll have a look at what could cause the reset on reboot, obviously, that’s not supposed to be how it works. i will let you know more when i do.

there is a command-line utility that will do this for you:

> rsh-data-forward 
Turn data-forwarding ON or OFF
usage: rsh-data-forward [ ON | OFF ]

RF562: Data Forwarding is currently ON

run without arguments for usage details, like above.

apologies for the troubles,

1 Like

Hello Richard,

Thanks for the command line instructions. That is definitely what is happening. Note when I first use the command, it says that data forwarding is on. If I then proceed to turn it off and then back on again, it starts streaming data that I can now see on shake net and in rs.local, ‘Server Connection :’ changes to ‘Connected’. I think I can work with this for now. Once again, thanks for your help.

Dr. Ward

1 Like