RS is getting HOT since a few days?


Since a few days my RS is getting HOT +/- 80 degree C, i now it should not be a big problem, yet i try to figure out why ?
I did see it has problems transferring data to the RS community, Gate errors and changed websites from Gempa/RS hopefull someone have a solution, so my RS gets back to the original say 65 Degree C.
Thnx in advance,

Hans Rolvers
RSH.R30D5.2019-06-06T21_51_11.logs.tar (2.4 MB)


Hi Hans,

We are looking into this, but it appears to me that you have a fairly constant connection from, which means that OWS (OSOP Wave Server) is pretty consistently using an entire CPU core (see mem-usage.out and ows.log). It’s hard to tell if there are duplicate connections from that device, but if there are, it would compound the computing power needed to serve all of the data requests. It may help to restart to close any connections that are lingering in a background process.



Hi Ian, Thnx for looking into it,

Its since a few days, no clue why, have gate errors, and the Velocity at Gempa/RS website stacks up till way high lvl, afther refresh webpage its normal.
Its seems RS is not refreshing, same for SWARM, it stacks up and i gues by that it gets hotter and hotter.
I did a fresh software install, did not solve the problem, so beats me.
Will keep and eye on whats going on.

Thnx again for reply,

Greetings from Yogyakarta
RaspberryShake Live near Volcano Merapi (Youtube)


Hi Hans,

We (Richard and I) think it’s probably SWARM that’s causing the Shake to heat up. It looks to me like there may be multiple SWARM connections all competing for the Shake’s attention. If you want to test this theory, you can turn SWARM off for a few hours and see if the CPU cools down a bit.



Oke will try Ian, i had a Beta version from Github,. Perhaps some hidden stuff was in it.

Oke will see what happens,

Thnx for advice and greetings to Richard and Mike,




Still bussy on the heating prob, yet still have this Error message.

Thnx for solving @server side,



Hi Hans,

I think Montana came up with a solution to this problem this morning, can you check to see if it still happens for you?



Hi Ian,

Well I did a fresh install software, and since the Gate error is solved all went back to normal.

69 70 degree C with SWARM full on job, so seems problem solved.

I did a check on the possible “ second” user, there was no one using the RS to, so all safe on that side.

Thnx for Support,

Happy weekend,



1 Like

Good to hear, Hans. Cheers