RPi Shake offline on app and web, accessible over SSH


Since today, our Shake has stopped sending data to the server.
Device is accessible via SSH.

Logs are attached.
rsh.logs.tar.bz2 (97.7 KB)


Hello shavrils,

Thank you for the logs. From them, nothing really out of place emerges, but yes, I cannot see a constant stream of data coming out from your Shake.

The first thing you can try (if you haven’t already) is simply to shut down your Shake from the rs.local web interface, then your modem/router, wait a couple of minutes, and then turn on again the modem first and the Shake second, to see if it was a simple issue with the modem/router itself.

If this has not solved the issue, then please shut down your Shake again first, then your modem/router. Wait for a couple of minutes, then restart your modem/router, and when it’s back online, please check from your pc/laptop if the following ports are open (do not start the Shake now):

port 55555 [TCP]
port 55556 [TCP]
port 123 for TCP and UDP traffic in both directions

After checking this (sometimes the modems close them without prompting) and opening the ports, if needed, please start your Shake, wait for around 10 minutes and then let’s check that your unit can reach our servers. Can you SSH into the Shake again and try and ping the following addresses?

  • ping -c 10
  • ping -c 10

The first one is the Google server, while the second is our data server. The two commands will execute the exchange ten times, and your expected result is a 0% packet loss for both instances.

I’ll wait for you to try this before going forward.

If you can, after all these restarts, save and send to me the new logs, so I can see if some difference (or a clearer reason for the issue) appears.


I am now seeing normal updates to our servers, so whatever must have happened has likely solved itself, if you have not intervened.

Your station is visible here: RS StationView