Router doesn't see RS

Several months ago I replaced my router after a storm. Since then my system has not seen the RS.The RS has always been on a surge protector/battery backup. Also,Fing does not see the RS. I see only steady blue and red lights on the RS. I tried burning a new SD card and it didn’t even allow the RS to start, only the red light came on briefly and they went off. I had been connecting the RS via wifi but still have the problem when I wire it directly to the router.

Is the card bad? Is the router or the RS bad? Help!

Dick Webb

Hello Seismiccat,

If you see only the blue and red steady LEDs, then this could mean that

  1. the microSD card has been corrupted, or
  2. that the Pi board has been damaged in some way.

Since you already tried to re-burn the microSD card and this didn’t provide any positive effect, I can suggest to

  1. try to replace the Pi board with another one that you are sure it is working, and use a freshly burned microSD card to try and start the Shake, or, a bit easier,
  2. re-burn the microSD card again, or use a clean one if you have it at home, and try to start the Shake (as a test) without the surge protector/battery backup, to see if this issue could be a problem connected to low power supply.

If you can check this, the Shake should have a constant 2.5A current and between 5.0V and 5.2V voltage to work.

Naturally, a third solution would be to change your router and see if everything works with another one, but since I think you can connect other devices to the same router, this should not be the problem. It is also possible that you have to intervene manually inside the admin panel of the router to enable connection to/from the Shake, but this is quite rare, so I’m adding it for the sake of being complete.

Thanks Stormchaser. I have a new microSD on order but I’m wondering if I go the route to replace the raspberry pi board is there a recommended version? Does Bluetooth connectivity work with shake?


I ordered and burned a new microSD card. Unfortunately, it did not solve the problem I still had only a single blue and red light. I suspect I need a new raspberry pi board. Assuming that’s the case what model board do I need. The one specified on the raspberry shake site seems to be unavailable or priced ridiculously high.

Thanks for the help,


Hello Dick,

I’m sorry to hear about the fact that a newly burned microSD card has not worked. If that is the case then, yes, the most likely responsible is the Pi board, that cannot read out the card itself, and thus the Shake OS doesn’t even start, leaving only the power LEDs on (the blue and red one).

Many models of different boards are supported via our Shake OS, and if you haven’t already seen it, I will add the complete list for your convenience: Technical Specifications — Instructions on Setting Up Your Raspberry Shake

Unfortunately, regarding the cost, there is an ongoing worldwide chip and other microelectronic components shortage that started some months ago and it is still continuing. This has caused inflation in general end-user prices for many products.

I can only advise to look for possible good occasions on different online shopping websites, or, asking some colleagues/friends if they may have a spare Pi board that they can give to you. I also wanted to buy a new Pi 4B for a project that I was keen to start, but had to refrain due to the increased costs…


I see the list and I think I’ll follow your advice and wait until the prices drop a bit. Or maybe a lot. Meanwhile I’ll follow somebody who lives within a couple miles of me who also has a shake.

Thanks again,