Reloaded SD Card Not Working

#1

My SD Card went (no green light). Followed directions to reload. Everything appears to be working and my router actually “sees” the Shake (IP address and MAC are all good). But the router shows NOTHING in TX and RX Rate (after a few hours). And rs.local does nothing (no connection). It’s there. Connected to the router but just not “talking” to it. Frustrating in that I feel like I’ve gotten to the 1 yard line but can’t score the touchdown!!! Anyone have any ideas???

#2

hello,

sorry to hear the regen didn’t work. but to be clear: did you buy a new SD card and burn that, or did you burn the SD card that stopped working?

if the latter, then this is likely the problem since reburning and SD card will likely not correct a corruption issue.

in any case, if you do detect the Pi is on the network, try to log in (instructions here) and retrieve the log file “postboot.log” from the /opt/log directory and post that back here.

cheers,

richard

#3

You’re right. I did NOT buy a new SD card. Let me do that and try again. I’ll let you know what happens. Thanks for the help.
Zyg

#4

Zyg:

Buenos días.

Did the original microSD card come from Raspberry Shake? If so, please send a photo of the card.

When purchasing a new microSD card, be sure to buy MLC-grade: http://manual.raspberryshake.org/burnSD.html

branden

#5

I’ve purchased a MLC-grade SD today. Should be here in 2 days.

In the meantime, I did have a “normal” 32 GB SD card in a camera that I also reformatted and loaded with the firmware. After installing it, the EXACT SAME result. System boots. Green light lights. It appears on the router. But rs.local just sits there and does nothing. It never connects.

The previous email I received referenced directions on how to retrieve the log on the device but nothing was attached to the email. Can you resend those instructions?

So while the new SD card will be here in 2 days, I worry it’s not going to be any different. (Though per your instructions, I’ve included a picture of the current card. It’s the SD card that “came” with the Shake as I purchased a “turnkey” solution.)

I’m worried that I’m not unzipping the files correctly or not moving the correct files to the SD card.

Also, in the past, I was able to talk to the device through the network (not via the cable). That is NOT working today. The router is not “seeing” it unless it’s plugged in via a cable. When connected via the cable, the router “sees” it but doesn’t transmit any data to or from it.

Thanks,

Zyg

#6

So did you do a MD5sum check on the zipped file ?

Did you wait 10 to 20 mins for the program to resize file system and then reboot ?

Followed SD card setup.
My sd card quit, first power up shows activity on router but no valid IP activity.
Waited under 10 minutes and then the RPI shake rebooted. Web page came up.

Hope that helps.

1 Like
#7

Please give it some time as @k21 suggests.

You need not worry. Over a thousand Shakes are up and running fine. We are also here to help.

OH great. It is a TLC card, not MLC. We moved to MLC back in July, 2018 which tells me you have been Shaking for a while now!

You mean via Wifi. You will need to reconfigure wifi at rs.local once you get things up and running again.

Naturally. The microSD card image you downloaded from the cloud knows nothing about your local Wifi connection …

Let’s see how you get on when the new MLC arrives.

Saludos from somewhere over the Atlantic Ocean,

branden

#8

Received the new Commercial SD card.

Formatted it as FAT32 on my HP Laptop.

Downloaded and unzipped the file using 7-Zip.

Installed it.

Lots of “green light” flashing and blinking.

Waited an hour.

Same problem. rs.local does nothing.

My router says the Raspberryshake is “there” but shows no RX or TX data.

This is EXACTLY what happened with the other two SD cards I tried.

If there are instructions for accessing some data on the Shake (or my router) to see what’s happening inside of it, please let me know.

FYI: This is the same router and router-settings that the Shake worked great on about a year ago.

Very fustrating.

Zyg Gorgol

#9

Zyg,

Have you been trying to go to rs.local exclusively or have you also tried going directly to the IP address?

Ian

#10

I typed in http://192.168.1.97 from Safari on my Mac and it did nothing.

I typed it in from my HP Laptop AND IT WORKED. I set up my device. ALL IS GOOD!!!

I know that in the past I could use Safari and have it work pretty well. So I guess my only question is whether there’s a way for me to use Safari on my Mac. Any thoughts, or should I just not even try???

Thanks for all your help. I feel like a dope for not trying it on my other computer sooner!! You guys are the best.

Zyg Gorgol

AM.RC5F0.00.SHZ

2 Likes
#11

Thanks Zyg, glad to hear it worked. I don’t know why Safari would be having trouble with it. I would try with and without a trailing slash to see if that helps (http://192.168.1.97 and http://192.168.1.97/). I’m curious, what (if any) error message does it give you?

Ian

#12

OK folks. I think I’m on to something. rs.local works great on:

  1. My HP computer running Windows
  2. Macbook Pro running 10.13.6 High Sierra OS

It does absolutely nothing (just sits there and doesn’t connect) on my MAC running 10.14.5 Mojave!!

Searching around the internet I found some discussion about how things changed in Mojave and some communication protocols are not supported any longer. Given that I don’t know what the heck I’m doing when it comes to subtle changes in communication protocols in Mojave I’m just saying there may be “something there.” I leave it to experts who may be reading this to tell me if this is nothing (my MAC is just flooky) or if there is a warning/necessary fix for people who want to use rs.local to connect to their Shake via Safari OR Chrome (neither work) with Mojave.

Thanks again for all the help. My Shake is up and running and doing great.
Zyg

#13

Hi Zyg,

No worries, we’ll try to test it out regardless. Glad to hear it’s working.

Ian

#14

Follow-up question for @zgorgo:

Can you ping or ssh your shake from the Mojave Mac ( using rs.local or IP )? Just trying to figure out if this is purely isolated to the web app or a complete communication failure on Mojave’s part.

Thanks.

#15

Typing in rs.local AND typing in the IP does nothing in Mojave. It just sits there and doesn’t connect.

I went into Terminal and “pinged” it and I DID get a response back.

So Terminal can find it and knows about it. But the “higher level” communication does not work.

Hope that helps,

Zyg