Post editing

At one time I was able to edit an entered post. This option seems to have gone away. Bug or user error?
Thanks for your help.
David Drake

Hello David,

In the latest Discourse update, the editing option should appear when you click the three dots just left of the Reply button in your message.

If that doesn’t appear, I can advise you (if you haven’t already tried) to log out from the forum, clear your cookies/cache, and then log in again.

If, after this, the option is still not there, can you send a screenshot of what you are seeing so that I can investigate a bit more? Thank you!

Here is the screenshot left of the reply button. No edit seen. I might be missing something so advice is encouraged.

Just checked a post of mine, and the edit option is readily available:

Maybe try the log out clear cache, etc as Stormchaser suggested?


It looks like only the last post in a sequence is editable. Bug or feature? I would like to add comments into the code in the first post.

Hello David,

After checking, the edit limit for basic usersl is seven days, so if your post is older, you will not be able to modify it again.

At this point, I would recommend simply updating the topic with a new post where you can add all the improvements you have made to your code.

Thanks, Stormchaser, that makes it much clearer.