Odd Network Behaviour

My Raspberry Shake and Boom is running and appears online on ShakeNet, but the green LED is not flashing and the blue and red LEDs are on solid.

I cannot connect to the RS&B using rs.local or it’s IP address. SWARM does not connect directly, though it can through the RS Community link. Fing finds the RS&B at its usual IP address (

I tried disconnecting the ethernet cable and reconnecting but I’m reluctant to power down the RS&B without being able to shut it down first.

Any ideas why I can’t connect directly? Should I do something about this or just wait and see?



BTW my station name is R21C0, and I have since reset and restarted my router, which has made no change except that now the feed to ShakeNet has stopped as well.


Hello sheeny,

I can indeed see that data flow from your station stopped around 03:23 UTC, and has not restarted.

Unfortunately, without logs I cannot provide more precise solutions. If nothing that have you tried works, then you will have to force-shut down the Shake by pulling the power supply, and then turn it on again. Likely, this will cause no problems, and, at worst, you will need to re-burn the microSD card.

The fact that the blue and red LED are solid is normal, but the missing flashing green light is what is probably indicating the lack on data transmission.

If, after restarting the Shake, you are able to download the logs, please do so and post them here, so that I can try to see what may be causing the problem.

OK, I’ve powered the RS&B down and back up again.

Green LED flashed twice quickly when I connected power, but not since. No change.

Looks like I’ll be burning the microSD card again in the morning.

The logs can only be retrieved via the web interface, is that correct?



OK. Burned a new microSD card and now have the RS&B back up and running.


Hello sheeny,

To answer your question, yes, the logs can be both retrieved from the web interface or the microSD card itself if you can access it directly.

It’s great to hear that now everything is working fine again! If this happens again, please feel free to check if your power supply is constantly providing at least 2.5A and between 5.0V and 5.2V. Sometimes repeated microSD card failures can be caused by insufficient power supply, and some users have solved it by changing it, or adding a PSU regulator between the Shake and their wall plug.

OK. How are the log files accessed directly? I swapped the microSD cards, so I have the card available from the problem.

Looking at the microSD card though, I cannot see any files that look like the log files (I compared against previous log files I submitted before). Nothing in the root partition and the other partition is not a recognised format.

I think I might have to look into the PSU regulator. I live in the country so long lines can sometimes means higher than expected line voltage.


Hello sheeny,

The log files are contained in the folder /opt/log/. There are many of them, so when you access it, it is better to take them all and then zip them into a single archive.

If you don’t see them via the classic Windows interface, you may have to navigate the microSD card via command line. If you cannot still find it, then maybe that was the cause of the problem, and some file (other than the logs) was not being correctly written or updated.

Yes, I have one since I live in a small town not close to big power lines, so every now and then we have a fluctuation. Since the Shake does not consume a lot of power, you can easily find a small PSU (if it also has LAN protection, even better) that you can add to your system.

Yeah, no good.

No /opt/logs/ folder (tried both windows and cmd line).


Now to look for a PSU…


1 Like