Not getting continuous data


My 1D Shake is have problems nowadays. I do not get continuous data. Please see the helicorder-picture, where I only get a few minutes of data at the time, and then nothing for a while. The Shake-net app shows the same thing. I have also attached the log files.

It has been like this since I replaced the sd-card a few days ago. Before that it had been running fine since 2017, but it stopped and it seemed to me that the sd-card failed. So I replaced that and got it back online, but it is not running so smoothly. I believe it is set up same way as before (connected to the router with cable) when it was running fine.

Can you help me with solving this problem?

Best regards
Eigil Haugen!

RSH.RF92D.2021-04-01T06 16 41.logs.tar (1.7 MB)

Hello Eigil, welcome to the community!

Thank you for the logs. From them, it appears that there is a combination of errors, I’ll list them:

2021 091 06:07:03>> Time adjustment M0: HARD RESET. This will result in a one-time time-tear.
2021 091 06:07:03>> 5.0: NTP Time (Init): NTP: 1617257222.708330393
2021 091 06:07:03>> 5.2: NTP Sync (HARD): VEL Before: 1617256859.674999952 After: 1617257221.667999983 Diff: 361.993000031

The first one is this, where it seems that the Shake loses the connection to the internet and thus loses also the connection to the time synchronisation services. Without these, the Shake does not transmit data to our servers, because it would be off-time, and the result is that you see what you are seeing on ShakeNet.

|2021 091 06:16:40>>|Data has been successfully received, fatal condition resolved.|

|2021 091 06:16:41>>|No Data has been received from the MCU in 14 read attempts.It appears the MCU is not transmitting data. This is a fatal condition and should be investigated if this condition persists!

This is the second one, and the reason why you see the gaps in the local helicorder. It indicates that every now and then there is no communication between the Shake OS and the Shake blue board/geophone sensor.

I would advise you to check all contacts between every component, check if the power supply is still working properly (the Shake needs from 5.0V to 5.2V and 2.5A), check if the Raspberry Pi board is working fine and, lastly, you can try to re-burn the microSD card or try with a completely new one, to see if the issues are caused by corrupted files.

1 Like

Thank you for quick help. I tried replacing the power supply and it worked! Now all seems to be in order.


It’s no problem at all Eigil, I’m glad that everything works fine now!

We have had some users with similar power-related issues, and we have adopted suggesting checking or changing the power supply in such cases.

Thank you for your feedback, and enjoy your Shake again!