Faulty Ethernet Port?

Setting up the RS4D (R7142) in a new location with static IP. It was connected for a short time but it seems to have issues with the ethernet port.
Sometimes the ethernet port light simply will not light up at all, other times without rhyme or reason it lights up again, but it hasn’t been available on the network since the third time it dropped. This behavior is pretty random. We’ve tried swapping ports on the router, changing cables, etc. but nothing worked.
At this point we haven’t been able to access the rs.local page through its IP and thus can’t download the log files. It seems that we can’t give much more info without that access…
My Shake and DataView don’t show it as disconnected but no data is streaming.


when you say “new location”, does this imply it was working in a different location previously without issue? if so, were you using a static IP over there as well? how hard would it be to (re)-create the situation corresponding to “last known working state”?

if that is not possible, or does not produce any information of interest, try to re-flash the SD card with the Shake-OS image which can be found here.

when that fails to resolve your problem, you will need to ship the unit back to be investigated by the hardware team. however, it is unlikely that the source of the problem is the ethernet port when the unit was working in one location, and then when moving to somewhere else simply stops working.

it is more likely related to some difference between the two networks.

please let us know your findings.


Thanks Richard,

The shake was configured in another location on static IP, but it did have some of the same issues as well then, after rebooting, it took a very long time before it could reconnect. We had to power cycle the thing several times before it would come back up. So it might be the same issues we’re having now at the second location (same network though).

Today we were able to connect to it with a crossover cable, but it continues to drop the connection (for example twice in five minutes). At one point we were able to download the attached .tar file, hopefully its helpful. The usual rs/local page didn’t have the option to download the logs:

disk-usage.out (15.7 KB) gpsd-mgr.log (4.3 KB) mem-usage.out (42.0 KB) myshake.out (9.3 KB) myshake.out.save (9.4 KB) odf_SL_plugin.dbug (220 Bytes) odf_SL_plugin.err (8.3 KB) odf_SL_plugin.info (20.4 KB) odf_SL_plugin.log (11.5 KB) ows.log (26.8 KB) postboot.log (3.0 KB) postboot.log.old (94.3 KB) purge-super.log (1.3 KB) rsh-data-consumer.log (74.1 KB) rsh-data-producer.log (15.9 KB) rsh-fe-hst.log (6.9 KB) rsh-fe.output.log (58.7 KB) rsh-fe.server.log (339 Bytes) seedlink.log (78.3 KB) slarchive_127.0.0.1_18000.log (1.9 KB) SLPurge.log (2.0 KB) Uploading: system-tty.log… upgrade.log (476 Bytes)

thanks for the files.

it does appear to be having issues connecting to the internet (see file postboot.log), though exactly what is the source / cause of this problem is unclear. would it be possible to connect it to the network via WiFi? the results would be informative either way: when it behaves as expected, or when it still fails.

another test would be to take it to another location altogether, where none of the LAN infrastructure is the same, e.g., to your house if you’re doing this at work, or vice-versa.

also, what happens when you connect it directly to a computer to access it using the discovery IP? (details here)

another test would be to boot with a different SD card and see if the behavior changes or not.

in summary, collect the results from the following tests:

  1. connect via WiFi
  2. boot on a completely different LAN network
  3. connect directly to a computer and access via discovery IP
  4. boot using a different SD card

when the problem is the ethernet port at the HW level, the WiFi connection should work as normal. when it’s not the ethernet port, i would expect tests 2, 3, and 4 would also all fail (obviously).

hope this helps, let me know the results so we can determine if the unit should be sent back or not.


Thanks Richard,

I can quickly respond to the wifi test. I have multiple Rasberry shakes which I have tried to connect to wifi, but I repeatedly am told that the wifi credentials are invalid while testing the wifi. I’ve tried this many times and am confident that I have given the correct password, so I’m not sure how to test via wifi.

I am connected right now to another Raspberry Shake on rs.local trying to connect it to the wifi and keep getting the same invalid credentials message…

hmm, not sure why setting up the WiFi through the interface isn’t working, strange.

you also have the option to do this manually, which is straightforward:

  1. log in to the Shake from the command line with ssh
  2. edit the WiFi connection file and specify the SSID and PW:
  1. enable WiFi and reboot:
> sudo wifi-cmd WEY
> sudo reboot

on reboot, both ethernet and WiFi interfaces should come up.


1 Like

How do I edit the WiFi connection file?

oh, sorry, i inadvertently left off the filename…

use any editor you prefer, nano is the most straightforward:

> sudo nano /etc/wpa_supplicant/wpa_supplicant.conf


1 Like