Error when testing rsudp with custom data


I am trying to test the rsudp package with historic data to perform a comprehensive review of performance for my region. I have gone through the documentation of the package and everything seems to be working fine, except for the rs-test module:
I can run rs-test (with no options specified) just fine, but when appending .mseed recordings as explained in the docs, there are 2 problems:

  1. The -i option does not exist (switched to -f according to the inline help)
  2. When running rs-test -f my_data.mseed a .txt file is created as it should, but I get the following error: ``index 15593 is out of bounds for axis 0 with size 15593"

It looks like a simple indexing issue in the code, but I was wondering if anyone else had the same issue and how they resolved it?
Thank you!

Hello a.f, welcome to the community!

Thank you for the detailed explanation of the issue, it was very useful.

To check, since I didn’t read it in your post, are you executing the rs-test command with the options from within an environment in which obspy is installed as a python3 package?

This is required because the function to convert the data files, called rsudp.packetize.packetize(), needs that package information to work properly, as shown here on the guide:

In the case this doesn’t work, can you please upload your .mseed test package so we can try with that one specifically? If the forum uploader doesn’t work, consider use some free service like dropbox, mediafire or similar.

Hi Stormchaser,
thanks for the warm welcome.
Yes, I am running rs-test within an Anaconda script where all the dependencies are correctly installed. I assume the packetize function works because the corresponding .txt file is indeed created in the same folder where the original .mseed file is stored.
I have tried running rs-test with several different .mseed files but I always get the same error. Attached are just two of the many files I tried, with no luck unfortunately.
Thanks for all the help!
fdsnws-dataselect_2020-09-11t01_46_46z.mseed (82 KB)

1 Like

Hello a.f, you’re welcome.

Thank you for the environment confirmation and for uploading your .mseed file.
I was able to recreate your issue with both yours and the ones from my personal Shake, getting also other inconsistencies on the rs-test command.

We are looking into this, and as soon as I have news and/or updates I will post them here.

Hi, the reason why your file doesn’t work is that it was recorded at a different rate than RS data, and rsudp can only display data at the two frequencies that different RS instruments record at. I apologize, the claim that it could read anything that obspy can is false. The qualifier to that should be “anything that obspy can read that has the same sample rate as the RS”. The docs have been updated to reflect this.



Hi Ian,

thanks for the reply. I am a bit confused, though. The previous post seems to suggest that rs-test does not run or is inconsistent even when using personal Shake files recorded from the RS directly.
If the problem is simply the sampling rate, resampling the data should solve the problem, right?

Yes, sorry for the confusion, resampling to 50 or 100Hz should do it.