Brand new Shake 4D not working


I just received my second Shake 4D and am having major issues getting it up and running.

I have already tried 3 different power supplies ( all > 2.4A), reflashing the SD card and even replacing the SD card. I sill cant get the shake to record data.

I have attached the helicorder display, and the log files.

Any help would be appreciated

RSH.R57A9.2023-05-19T06_22_58.logs.tar (445 KB)

1 Like

Hello kxd,

I’m sorry to hear about this issue with your new RS4D, and thank you for posting the helicorder and the logs from the Shake itself.

From them, it appears that, at the start, the Pi board was not able to see the blue Shake board above it:

2023 139 01:32:43: Unable to read Firmware version number off of Serial Port /dev/serial0 after trying for 15 seconds, cannot continue!
2023 139 01:32:43: Is the Pi computer connected to the Raspberry Shake Board?  Please confirm and try again.

Furthermore, these lines in the logs, tell us that there is something going on between the boards and the sensors:

2023 139 01:29:58>>	$ÁË1??IY ÙÆ?XEBe??QÒ?U???U?ÁÿÉÆwTBe??S:
2023 139 01:29:58>>	Y??Ñò?E?	?+%ÁÊ1TVI0ÉÇÊS?Re??Se?E?	?7W?ÑÊ!?EIY ÙÆ?B?Be?øT[??ÉÇ7UBe??Y?
2023 139 01:29:58>>	Y??Ö??E?	??a?ÑÊ!?fHY ÙÆG?Be??Sâ?U??fe?ÁË1VYI0ÉÇ7ÎUI0ÉǪS?Re??QT?E?	?6%ÑÊ1?HI Éƪ@?Be??Q??E?	?áEY ÙƪDUBe??e??U??w$ÑÊ!??DY ÙÆG?EBe??Se??Ok?M?D[2Q??Ê?AÀU
2023 139 01:29:58>>	'AA0KE

As you have already tried replacing the power supply and re-burning the microSD card, I would recommend checking if all the connections between the sensor, the blue Shake board, and the Pi board are still solid and free from dirt or any other element that could compromise transmission. If needed, you can find assembly guides here in our manual: Assembly Guide — Instructions on Setting Up Your Raspberry Shake

When doing this, please make sure you are using proper ESD (ElectroStatic Discharge) protection (such as gloves, etc.), as electronics do not like static electricity too much.

Could I please ask you to also post some pictures of the RS4D from different angles, so that we can take a look at it? Thank you.

If this check comes out as positive, then we can think about what other options we have, but let’s see what the new analisys brings.

Thank you for your collaboration!

I swapped the 3B+ I was using for a 4B and its working now, I guess there must be something wrong with the GPIO on my 3B+.

Anyway for me to remove the station R57A9 from my account?

The new station ID is RFB84.

1 Like

Hello kxd,

Glad to hear that you were able to fix the issue, it is probably as you say, but now that you have the board out of the Shake, you will be able to test it more at your leisure.

If you go to the ShakeNet portal, then click on My Shake on the left menu. Both your Shakes should appear on the page that loads, but the offline one should have a broken chain icon on the right of its code that says, Disassociate this station. Just click on that, and you’re good to go.

Thanks for that info, but I don’t see that option anywhere on the page.

1 Like

Hello kxd,

Thank you for the screenshot. I will ask for more details and get back to you as soon as I have news.

Thanks for your patience.