Booting for more than 15h

Dear all,

We have a RS3D installed in a mine, connected to the net with a sierra wireless modem. It worked fine for more than a month, then it started to do data gaps in the data sent to raspberryshake server, but also in the data stored in the microsd and sent by seedlink to our seiscomp.

We moved it to another place it worked fine for a week. And when we reinstalled it in the mine, it stalled in the booting process.

See attached screenshot and logs.

Is there something we could do remotely? Perhaps is the microsd corrupted??

Best regards
Mario

RSH.R45B5.2024-06-15T07_23_41.logs.tar (3.9 MB)

1 Like

Hello Labsis, and welcome back to the community!

Thank you for both the screenshot and the logs from your Shake, together with the description of the overall situation.

What you describe is also supported by some information (or, rather, the lack of it) in the logs themselves:

  1. The device “stuck” in a BOOTING status, with the software not able to see the Shake board:
2024 166 15:52:29: Unable to read Firmware version number off of Serial Port /dev/serial0 after trying for 15 seconds, cannot continue!
2024 166 15:52:29: Is the Pi computer connected to the Raspberry Shake Board?  Please confirm and try again.
  1. Some unusual output mixed in the normal log one, below:
2024 166 13:35:00>>	Y???ÔU?ÙÊ,$ÁËQ??TI0ÉËpE
2024 166 13:35:00>>	Y??ØY?ÁËQ?\YÿRe?IÇPU
2024 166 13:35:00>>	Y??H?ÔU?ÙÊ,

As you can see, errors are mixed with some ‘gibberish’ that cannot be successfully interpreted (that could be causing the issues you are seeing). My first thought (and I think that this may be the main reason why the Shake is not working in the mine) would be to check and see if the current power supply you are using in the mine is continuing to deliver a stable voltage between 5.0 and 5.2V and a current of at least 2.5A at all times, as a decrease in power could lead to data services interruption and data gaps, as the ones you are seeing.

As the you already tested the Shake in a different location, where everything worked fine, I don’t think that the next two suggestions are relevant, but I am attaching them for completion.

A second check that you can do is to see if all the connections between the sensor, the blue Shake board, and the Pi board are still solid and free from dirt or any other element that could compromise transmission. As usual, if you decide to disassemble the Shake when doing this, please ensure you use proper ESD (ElectroStatic Discharge) protection (such as gloves, etc.), as electronics do not like static electricity too much.

As a last resort, and if all these checks come out as positive, then I would recommend re-burning the microSD card again (or using a different microSD) after formatting and erasing all its data/partitions first (you can use DISKPART for this as it is very efficient), and see how the Shake behaves with the newly installed system, removing potential issues derived from corrupted files. I will leave the burning instructions link here for your convenience: microSD card topics

Thank you for your collaboration.

1 Like

Thank you very much for the fast and complete answer.
RS is working with a 50Ah-12V battery and a 60W solar panel. We will check the 12 to 5V converter, perhaps it has been damaged during the last movement… Lets see if I can chek it this afternoon!

Thank you very much!
Regards
Mario

2 Likes

Solved! At least for the moment! Let’s cross the fingers :wink:

As you pointed it was a problem with the input voltage/power. We replaced the 12V to 5V converter and the RS3D started to work again!

Thank you very much for your help!

Regards
Mario

2 Likes

Hello Mario,

Happy to read that, and glad that I could help!

1 Like