4D WiFi Issues


I’m trying to connect my 4D (AM.R4F18) to the WiFi, but I’m having some issues.

On the WiFi page, it wouldn’t successfully test the WiFi password with my access point. I tried three different access points and it would all fail testing the WiFi password.

I thought it worked once and I hit “Save and Reboot”, but now when I try to check “Connect to WiFi”, I would get an error “Failed to turn on WiFi, please check your Raspberry Pi for hardware issues.”
Now it will only pop up that latter error if I try to check “Connect to WiFi”.

I’m still using an ethernet connection to it now, but in order to move it down to my garage, I need to go to WiFi.
Logs attached.

Edit: This is a Pi 4 Model B - 4GB RAM, but shows up as UNKNOWN device name on rs.local.
RSH.R4F18.2021-10-23T23_56_06.logs.tar (391.5 KB)

Hello ChuoDori, welcome to the community!

Thank you for the details about your experience, and the logs that you have posted. Since the same logs show that the WiFi is correctly enabled when the Shake starts, there has to be something that is preventing its connection to the network.

Could you please try to re-burn the microSD card to see if this behaviour with the WiFi configuration is due to some corrupted file? You can follow these steps:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

After you have done this sequence, please wait for the Shake to re-download the new operating version so everything will be updated to v0.19. It should not take long and, hopefully, the update will be done as it should.

Otherwise, the v0.19 image should be going live in the coming days, so you could wait for that to come up and re-burn the microSD card with the new version directly.

Hi Stormchaser,

Thanks for getting back to me!

I followed your instructions and re-burned the Shake OS image.
It looks like it self-updated to v0.19 upon bootup.

Unfortunately, it looks like I’m getting the same issue with the “Given credentials were not valid” error message when I’m trying to confirm my WiFi credentials by hitting “Test WiFi”.
Again, I tried over 3 different SSIDs I know the network password for with the same results.

Updated logs attached.
Thanks for your help!
RSH.R4F18.2021-10-26T21_03_24.logs.tar (129.5 KB)

Hello ChuoDori,

Thank you for re-burning the card, in this way we are starting from a fresh install (and it’s great that the update process has gone fast and well) and we can analyse things better.

Could you please re-post the new logs? It seems that in your last message something has gone wrong, and they cannot be downloaded.

Thank you!

Hi Stormchaser,

Whoops, looks like it was on the same line as my message and broke it. I’ve edited my previous post so it looks like it’s fixed. But just in case, I’ve attached fresh logs.

I just tried performing the WiFi setting change in Chrome (Ver. 95.0.4638.54) and Firefox (Ver. 93.0) just in case, and still experienced the same issue.
I’ve also noticed that that Server Connection would stay “Not Connected” and not forward data, despite it being checked, until I hit Save and Restart on any screen that has it. Not sure if that’s related though.

Please let me know if there’s anything else I can try to troubleshoot on my end!
Thanks again.

RSH.R4F18.2021-10-28T00_47_30.logs.tar (218 KB)

Hello ChuoDori, no problem at all, thank you for the new logs.

The Shake boots up properly, and manages to find all the related network connections, albeit via LAN and not via WiFi, which still results deactivated.

Regarding the “Not Connected” issue, there is a quick fix with the procedure below:

Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Try unchecking the Forward Data box and, after ~30 seconds, recheck it. Then,click save and restart.

The station should now be able to connect again.

This could be an undiscovered bug related to the use of a Raspberry Pi 4 board, which was not seen until now. I will try to reproduce the issue with my own RPi4 board, and see if I can find a solution.

In the meanwhile, you can try to manually add the WiFi network to the Shake configuration files. If you want to try this, please log in into the Shake via SSH (instructions here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake) and then follow the steps in this other manual page: How to configure Wifi and USB wifi dongles from command-line — Instructions on Setting Up Your Raspberry Shake

If you need further assistance, I am here to help.

Hi Stormchaser,

Appreciate the help!
I had a spare RPi4 of the same model that I swapped in with the current one in the Shake and was able to reproduce the exact same issue.

The instructions to manually add the WiFi network via SSH was flawless, and now it’s up and running in my garage.

Thanks again!


Hello ChuoDori,

This is fantastic news, I had seen your station going live on our network so I was crossing my fingers that everything went right!

I will try to reproduce the issue nonetheless, since it seems related to Pi 4 boards, so that we will be able to fix it in our next Shake OS releases.

Thank you again for your time and patience on this.

Enjoy your Shake!

1 Like

I know this is an old post, but I’m having the same problem and wonder if I missed a different solution to the problem of setting the WiFi up from the web page.

I’m running a few RS1Ds on Pi 4 Model B. They work fine over ethernet and also over wifi IF I set up the credentials using ssh. But I can’t get the WiFi set up using the webpage interface. I’ve just re-imaged the SD card to start from scratch and have the same issue. Running Ver 0.20.

I’ve been handing these off to teachers and would like them to be able to easily configure them for wifi. Not a major issue, but would make things a little simpler.

Thanks for any help.
RSH.R85D6.2022-05-04T20_30_46.logs.tar (386 KB)

1 Like

Hello gregw8, welcome to our community!

Thank you for posting the logs from your Shake. It seems that our OS correctly recognizes the 4B Pi model, so the issue is not there and we can proceed forward.

It seems that the WiFi is actually turned off, together with the LAN:

2022 124 20:27:45: Ethernet is OFF and WiFi is OFF

And this makes the Shake unable to reach the internet, as you can surely imagine:

2022 124 20:24:52: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available
2022 124 20:24:52: No internet connection found
2022 124 20:25:07: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available

Can you describe to me your step-by-step procedure when you try to configure the WiFi from the webpage interface? The more information the better, so I can try to replicate the issue with my test Shake, and maybe gain more insight on where the problem may be.

Thank you for your collaboration.

Thanks for looking at the logs. It could be that I had rebooted while connecting to LAN so the WiFi was off. I’ll go through the steps again now and report how it goes:

  1. go to Network -> WiFi Settings and check the box to connect to WiFi
  2. select my router
  3. enter password
  4. in about 3-5 seconds the message “WiFi credentials are not valid” displays on the bottom and then disappears

Right now, the shake is connected to my router via ethernet.

I have tried with safari and chrome, and with several different routers. The result is always the same. But as I said, if I configure the wpa_supplicant file I can connect to WiFi without any trouble.

Thanks again for looking into this,

1 Like

Hello Greg,

You’re welcome, and thank you for the detailed walkthrough. I was, in fact, able to reproduce the problem that you are encountering, and I have passed it to our software development team so that we can take a look at it and see what can be done.

For any other user reading this topic, configuring the wpa_supplicant is, for now, the way to go for this, it worked for me too, since it basically bypasses the webpage. Detailed instructions on how to do so are here in our manual: How to configure Wifi and USB wifi dongles from command-line — Instructions on Setting Up Your Raspberry Shake

Thank you again for pointing this out for us!

Thanks for the follow up.